Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » TheIDE for Windows doesn't run
TheIDE for Windows doesn't run [message #51914] Wed, 19 June 2019 13:49 Go to next message
pvictor is currently offline  pvictor
Messages: 26
Registered: December 2015
Location: Russia
Promising Member
Hi,

The latest builds of TheIDE (13393, 13402, 13419) don't start on my Windows 10.
After choosing the main package, they close the window without any message.
Since no one complains, I think that it's my problem, however, build 13389
and all previous work OK.

An application error appears with no useful information.
Maybe, the line:
Код исключения (exception code): 0xc0000005
will help.

Any suggestions?

Thanks,
Victor
Re: TheIDE for Windows doesn't run [message #51915 is a reply to message #51914] Wed, 19 June 2019 15:57 Go to previous messageGo to next message
Xemuth is currently offline  Xemuth
Messages: 133
Registered: August 2018
Location: France
Experienced Member
Will try latest build in the evening on W10, I will tell you.

Re: TheIDE for Windows doesn't run [message #51916 is a reply to message #51914] Thu, 20 June 2019 07:57 Go to previous messageGo to next message
pvictor is currently offline  pvictor
Messages: 26
Registered: December 2015
Location: Russia
Promising Member
The newest build 13420 doesn't run as well.
Re: TheIDE for Windows doesn't run [message #51917 is a reply to message #51916] Thu, 20 June 2019 09:53 Go to previous messageGo to next message
koldo is currently offline  koldo
Messages: 3033
Registered: August 2008
Ultimate Member
Yes, I can confirm that in W10, theide.exe, as downloaded from here, crashes after choosing which package to open.
However, when compiled from sources with VS 2017 x64, there is no problem.

Comparing theide.exe size:
- From sources: 10943 Kb
- Downloaded: 13799 Kb


Best regards
Iñaki
Re: TheIDE for Windows doesn't run [message #51919 is a reply to message #51914] Thu, 20 June 2019 18:23 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 640
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello,

I can confirm that the crash is present. Here is the call stack of crash:
index.php?t=getfile&id=5860&private=0

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Re: TheIDE for Windows doesn't run [message #51920 is a reply to message #51919] Thu, 20 June 2019 18:31 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12106
Registered: November 2005
Ultimate Member
Klugier wrote on Thu, 20 June 2019 18:23
Hello,

I can confirm that the crash is present. Here is the call stack of crash:
index.php?t=getfile&id=5860&private=0

Sincerely,
Klugier


Fixed in trunk. Very stupid bug...

Mirek
Re: TheIDE for Windows doesn't run [message #51921 is a reply to message #51920] Thu, 20 June 2019 20:44 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 640
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello Mirek,

The crash is no longer observer - thanks for fixing this issue. Tomorrows nightly (21.06.2019) should not be affected by this bug and TheIDE should be stable as before.

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Re: TheIDE for Windows doesn't run [message #51922 is a reply to message #51921] Thu, 20 June 2019 21:42 Go to previous message
mirek is currently offline  mirek
Messages: 12106
Registered: November 2005
Ultimate Member
Klugier wrote on Thu, 20 June 2019 20:44
Hello Mirek,
TheIDE should be stable as before.


Probably not. This is period of significant changes in the Core, so instability of trunk is more likely than usual...

Mirek
Previous Topic: build_info.h last line not terminated
Next Topic: nightly build svn 13696M does not compile
Goto Forum:
  


Current Time: Sat Nov 23 02:36:33 CET 2019

Total time taken to generate the page: 0.03160 seconds