Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » Archive » Agg works with upp Ctrl's! - download and test the new package...
Agg works with upp Ctrl's! - download and test the new package... [message #3625] Fri, 09 June 2006 03:09 Go to next message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
I haven't tested on Linux and with MINGW. So, please test.
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3626 is a reply to message #3625] Fri, 09 June 2006 09:16 Go to previous messageGo to next message
masu is currently offline  masu
Messages: 378
Registered: February 2006
Senior Member
It seems the package 'nImage' is missing in the archive.

Matthias
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3627 is a reply to message #3625] Fri, 09 June 2006 09:24 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
fudadmin wrote on Fri, 09 June 2006 03:09

I haven't tested on Linux and with MINGW. So, please test.


I'll try it this afternoon. Is it running under stable 605 or someother version?

Luigi
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3628 is a reply to message #3626] Fri, 09 June 2006 09:50 Go to previous messageGo to next message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
masu wrote on Fri, 09 June 2006 08:16

It seems the package 'nImage' is missing in the archive.

Matthias



You should have "nImage" in uppsrc...
  • Attachment: nImage.zip
    (Size: 22.98KB, Downloaded 1743 times)
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3629 is a reply to message #3628] Fri, 09 June 2006 13:07 Go to previous messageGo to next message
masu is currently offline  masu
Messages: 378
Registered: February 2006
Senior Member
fudadmin wrote on Fri, 09 June 2006 09:50


You should have "nImage" in uppsrc...



I have release 605 installed and I can't find 'nImage' in uppsrc.
Which version do you use?

Matthias
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3630 is a reply to message #3629] Fri, 09 June 2006 13:37 Go to previous messageGo to next message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
masu wrote on Fri, 09 June 2006 12:07

fudadmin wrote on Fri, 09 June 2006 09:50


You should have "nImage" in uppsrc...



I have release 605 installed and I can't find 'nImage' in uppsrc.
Which version do you use?

Matthias



Because I like to experiment a lot I use my very own mixed versions... Smile. If you don't have nImage you can download from the post above.
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3631 is a reply to message #3630] Fri, 09 June 2006 14:31 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11701
Registered: November 2005
Ultimate Member
fudadmin wrote on Fri, 09 June 2006 07:37

masu wrote on Fri, 09 June 2006 12:07

fudadmin wrote on Fri, 09 June 2006 09:50


You should have "nImage" in uppsrc...



I have release 605 installed and I can't find 'nImage' in uppsrc.
Which version do you use?

Matthias



Because I like to experiment a lot I use my very own mixed versions... Smile. If you don't have nImage you can download from the post above.



nImage was package used to develop new Image. Since B605 version, what was in nImage is now integrated in regular Draw.

Mirek
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3635 is a reply to message #3628] Fri, 09 June 2006 21:11 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
fudadmin wrote on Fri, 09 June 2006 09:50

masu wrote on Fri, 09 June 2006 08:16

It seems the package 'nImage' is missing in the archive.

Matthias



You should have "nImage" in uppsrc...


I've put nImage package in uppsrc. Then the other two packages are now in MyApps. This is what I get with a stable 605 and mingw:
In file included from C:\upp\uppsrc\nImage\/Image.h:227,
                 from C:\upp\uppsrc\nImage\Image.cpp:1,
                 from C:/upp/out/nImage/MINGW.Debug.Gui/$blitz.cpp:3:
C:\upp\uppsrc\nImage\/Raster.h:64: error: expected `,' or `...' before '&&' token
C:\upp\uppsrc\nImage\/Raster.h:65: error: expected `,' or `...' before '&&' token
In file included from C:/upp/out/nImage/MINGW.Debug.Gui/$blitz.cpp:19:
C:/upp/uppsrc/Draw/Draw.h: In constructor `NewImageDraw::NewImageDraw(Size)':
C:/upp/uppsrc/Draw/Draw.h:389: error: `Draw::Draw()' is protected
C:\upp\uppsrc\nImage\ImageWin32.cpp:312: error: within this context
C:/upp/uppsrc/Draw/Draw.h: In constructor `NewImageDraw::NewImageDraw(int, int)':
C:/upp/uppsrc/Draw/Draw.h:389: error: `Draw::Draw()' is protected
C:\upp\uppsrc\nImage\ImageWin32.cpp:318: error: within this context
In file included from C:/upp/out/nImage/MINGW.Debug.Gui/$blitz.cpp:23:
C:\upp\uppsrc\nImage\RasterFormat.cpp: At global scope:
C:\upp\uppsrc\nImage\RasterFormat.cpp:118: error: expected `,' or `...' before '&&' token
C:\upp\uppsrc\nImage\RasterFormat.cpp: In static member function `static void RasterFormat::TailBits(RGBA*, const by
	te*, int, byte)':
C:\upp\uppsrc\nImage\RasterFormat.cpp:123: error: `palette' undeclared (first use this function)
C:\upp\uppsrc\nImage\RasterFormat.cpp:123: error: (Each undeclared identifier is reported only once for each functio
	n it appears in.)
C:\upp\uppsrc\nImage\RasterFormat.cpp:123: error: expected identifier before ']' token
C:\upp\uppsrc\nImage\RasterFormat.cpp:123: error: `shift' undeclared (first use this function)
C:\upp\uppsrc\nImage\RasterFormat.cpp: At global scope:
C:\upp\uppsrc\nImage\RasterFormat.cpp:129: error: expected `,' or `...' before '&&' token
C:\upp\uppsrc\nImage\RasterFormat.cpp: In static member function `static void RasterFormat::TailBitsMSB1st(RGBA*, co
	nst byte*, int, byte, byte)':
C:\upp\uppsrc\nImage\RasterFormat.cpp:134: error: `palette' undeclared (first use this function)
C:\upp\uppsrc\nImage\RasterFormat.cpp:134: error: expected identifier before ']' token
C:\upp\uppsrc\nImage\RasterFormat.cpp:134: error: `shift' undeclared (first use this function)
C:\upp\uppsrc\nImage\RasterFormat.cpp: In member function `void RasterFormat::Read(RGBA*, const byte*, int, const RG
	BA*) const':
C:\upp\uppsrc\nImage\RasterFormat.cpp:158: error: no matching function for call to `RasterFormat::TailBits(RGBA*&, c
	onst byte*&, int, int, int, const RGBA*&) const'
C:\upp\uppsrc\nImage\RasterFormat.cpp:119: note: candidates are: static void RasterFormat::TailBits(RGBA*, const byt
	e*, int, byte)
C:\upp\uppsrc\nImage\RasterFormat.cpp:176: error: no matching function for call to `RasterFormat::TailBitsMSB1st(RGB
	A*&, const byte*&, int, int, int, int, const RGBA*&) const'
C:\upp\uppsrc\nImage\RasterFormat.cpp:130: note: candidates are: static void RasterFormat::TailBitsMSB1st(RGBA*, con
	st byte*, int, byte, byte)
C:\upp\uppsrc\nImage\RasterFormat.cpp:190: error: no matching function for call to `RasterFormat::TailBits(RGBA*&, c
	onst byte*&, int, int, int, const RGBA*&) const'
C:\upp\uppsrc\nImage\RasterFormat.cpp:119: note: candidates are: static void RasterFormat::TailBits(RGBA*, const byt
	e*, int, byte)
C:\upp\uppsrc\nImage\RasterFormat.cpp:204: error: no matching function for call to `RasterFormat::TailBitsMSB1st(RGB
	A*&, const byte*&, int, int, int, int, const RGBA*&) const'
C:\upp\uppsrc\nImage\RasterFormat.cpp:130: note: candidates are: static void RasterFormat::TailBitsMSB1st(RGBA*, con
	st byte*, int, byte, byte)
C:\upp\uppsrc\nImage\RasterFormat.cpp:216: error: no matching function for call to `RasterFormat::TailBits(RGBA*&, c
	onst byte*&, int, int, int, const RGBA*&) const'
C:\upp\uppsrc\nImage\RasterFormat.cpp:119: note: candidates are: static void RasterFormat::TailBits(RGBA*, const byt
	e*, int, byte)
C:\upp\uppsrc\nImage\RasterFormat.cpp:228: error: no matching function for call to `RasterFormat::TailBitsMSB1st(RGB
	A*&, const byte*&, int, int, int, int, const RGBA*&) const'
C:\upp\uppsrc\nImage\RasterFormat.cpp:130: note: candidates are: static void RasterFormat::TailBitsMSB1st(RGBA*, con
	st byte*, int, byte, byte)
nImage: 11 file(s) built in (0:06.93), 630 msecs / file, 
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3636 is a reply to message #3635] Fri, 09 June 2006 21:23 Go to previous messageGo to next message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
I guess my agg package should work with any pre-new-image Draw. That means before B605? Luigi, have you tried with MSC?
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3637 is a reply to message #3636] Fri, 09 June 2006 21:29 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
fudadmin wrote on Fri, 09 June 2006 21:23

I guess my agg package should work with any pre-new-image Draw. That means before B605? Luigi, have you tried with MSC?


I've removed every track of MSC on my computer. Smile One day, perhaps, I'll try again to install this 1 gigabyte compiler. I think too the problem is the compiler and include. Let's wait what other users will report.

Luigi
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3639 is a reply to message #3637] Fri, 09 June 2006 23:44 Go to previous messageGo to next message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
forlano wrote on Fri, 09 June 2006 20:29


I've removed every track of MSC on my computer. Smile One day, perhaps, I'll try again to install this 1 gigabyte compiler. I think too the problem is the compiler and include. Let's wait what other users will report.

Luigi


Why on earth did you want the 8th version? MSC7.1 works very well and you don't need 1 gigabyte... If are you saving space you can e.g. remove from 600MB SDK - 200Mb help files, 100Mb samples, 150MB mfc libs... What is left? 150MB! You can strip it more if you are not using 64bit and win95 stuff....
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3641 is a reply to message #3639] Sat, 10 June 2006 09:00 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
fudadmin wrote on Fri, 09 June 2006 23:44


Why on earth did you want the 8th version? MSC7.1 works very well and you don't need 1 gigabyte... If are you saving space you can e.g. remove from 600MB SDK - 200Mb help files, 100Mb samples, 150MB mfc libs... What is left? 150MB! You can strip it more if you are not using 64bit and win95 stuff....

The link on the microsoft show me only the 8th version. Please indicate me the link of the 7.1 version.

Luigi
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3643 is a reply to message #3641] Sat, 10 June 2006 11:47 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
forlano wrote on Sat, 10 June 2006 09:00

fudadmin wrote on Fri, 09 June 2006 23:44


Why on earth did you want the 8th version? MSC7.1 works very well and you don't need 1 gigabyte... If are you saving space you can e.g. remove from 600MB SDK - 200Mb help files, 100Mb samples, 150MB mfc libs... What is left? 150MB! You can strip it more if you are not using 64bit and win95 stuff....

The link on the microsoft show me only the 8th version. Please indicate me the link of the 7.1 version.

Luigi


Today I had the courage to download again the version 8. It works Very Happy .
My program from 2.6 Mb passed to 1.75. Even the agg-aris application works. Now I must study the upp graphics.

Luigi
Re: Agg works with upp Ctrl's! - download and test the new package... [message #3645 is a reply to message #3643] Sat, 10 June 2006 14:11 Go to previous message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
If you have upp version (>=B505) with the new upp Image integrated (I've tested 606dev1 with MSC and MINGW) upp you can draw my agg image like this:
   //aggImg(600,400).Paint(w, 50, 50);
   w.DrawImage(50,50, aggImg(600,400));
Previous Topic: Draggable, detachable, docable, vertical toolbars...
Next Topic: DrawData and StoreImageAsString, how?
Goto Forum:
  


Current Time: Tue Feb 19 09:49:00 CET 2019

Total time taken to generate the page: 0.02301 seconds