Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Extra libraries, Code snippets, applications etc. » U++ users applications in progress and useful code snippets, including reference examples! » Linking has failed using mitielib
Linking has failed using mitielib [message #56384] Tue, 02 March 2021 16:37
nodebot is currently offline  nodebot
Messages: 3
Registered: January 2021
Junior Member
Hello,

I want to use MIT's mitielib library on my project. I compiled the project successfully but cant run it. It gives "Linking has failed" error when click to execute button on IDE.

I followed these steps.
1. Build mitielib binary files according to this instruction https://github.com/mit-nlp/MITIE
cd mitielib
mkdir build
cd build
cmake ..
cmake --build . --config Release --target install


mitie.dll and mitie.lib files created after build process.

2. Entered new created dll and lib files location on IDE setting. Added Lib, Include and Bin file locations from Setup/Build Methods menu.

3. Created a new project and added sample from mitielib.
https:// github.com/mit-nlp/MITIE/tree/master/examples/cpp/train_text _categorizer

4. Compiled successfully

5. Tried to run, failed with "linking has failed" error

Can you help me whats wrong or forgotted while using 3rd party libraries.

Regards,
Previous Topic: Compare and contrast - wxPython vs Ultimate++
Next Topic: findarg_r, a findarg variant that works with value ranges.
Goto Forum:
  


Current Time: Sat Jun 15 16:16:58 CEST 2024

Total time taken to generate the page: 0.01980 seconds