Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » MacOS 10.11? (Request about 1) last 10.11 compatible release 2) chance of current 10.11 build)
MacOS 10.11? [message #57082] Sun, 23 May 2021 00:44 Go to next message
elNb is currently offline  elNb
Messages: 1
Registered: May 2021
Junior Member
Hello, I'd like to know:
- which is the last version compatible (including TheIDE) with macOS 10.11.6
- is there any chance of up to date 10.11 compatible build
- else, hint for trying to compile myself
two initial problems:
- missing packages (freetype2 x11 fontconfig xcb xinerama xrender xft xdmcp xext gtk+-3.0 libnotify)
- "error: thread-local storage is not supported for the current target"
about packages:
- which are required (according to www$uppweb$uppx11$en-us.html "bash gmake gtk2(not 3?) freetype2 libnotify clang-devel" for a BSD build, but no macOS specific info)
- what is the advised way to install them, MacPorts appears to have most (all?) of them but I'm having trouble with the naming
- is the X11.app that comes with the OS of any use here (does not include development files, and must be rather old)
about compiler:
- what is the required clang++ version, will the one in Xcode 7.3.1 or 8.2.1 do (I yet have to install Xcode 8, perhaps that solves the thread-local error)
Thanks in advance for help.
Re: MacOS 10.11? [message #57085 is a reply to message #57082] Sun, 23 May 2021 13:23 Go to previous message
mirek is currently offline  mirek
Messages: 13996
Registered: November 2005
Ultimate Member
elNb wrote on Sun, 23 May 2021 00:44
Hello, I'd like to know:
- which is the last version compatible (including TheIDE) with macOS 10.11.6
- is there any chance of up to date 10.11 compatible build
- else, hint for trying to compile myself


https://sourceforge.net/projects/upp/files/upp/2021.1/
https://github.com/ultimatepp/ultimatepp/releases/tag/2021.1

Quote:

two initial problems:
- missing packages (freetype2 x11 fontconfig xcb xinerama xrender xft xdmcp xext gtk+-3.0 libnotify)
- "error: thread-local storage is not supported for the current target"
about packages:
- which are required (according to www$uppweb$uppx11$en-us.html "bash gmake gtk2(not 3?) freetype2 libnotify clang-devel" for a BSD build, but no macOS specific info)
- what is the advised way to install them, MacPorts appears to have most (all?) of them but I'm having trouble with the naming
- is the X11.app that comes with the OS of any use here (does not include development files, and must be rather old)
about compiler:
- what is the required clang++ version, will the one in Xcode 7.3.1 or 8.2.1 do (I yet have to install Xcode 8, perhaps that solves the thread-local error)
Thanks in advance for help.


Sorry, the makefile only works for X11/gtk posix. For macos you are supposed to use prebuilt binary. You can build from sources immediately after that (as there are tools to build U++ modular source structure included - theide and umk).

U++ requires C++14, so I think Xcode version does not really matter.

Mirek
Previous Topic: Copying package settings, state/session, and configuration to other systems
Next Topic: How to relocate upp.out?
Goto Forum:
  


Current Time: Wed Jul 24 19:42:36 CEST 2024

Total time taken to generate the page: 0.01747 seconds