Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » U++ community news and announcements » 2022.3rc1
2022.3rc1 [message #59353] Sun, 18 December 2022 19:56 Go to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Here we go:

https://sourceforge.net/projects/upp/files/upp/2022.3rc1/

Release highlights

Homegrown C++ parser in theide is replaced with libclang resulting in new and improved Assist++ features
Optimised memory consumption of U++ widgets.

MacOS version is not released with 2022.3. We hope to provide it again with the 2023.1.

TheIDE:

Autocomplete now correctly works in most cases (except in template bodies, which is libclang limitation)
Code navigator refactored and improved

TheIDE now shows C++ errors while editing sources

TheIDE now shows information tips about program symbols when you leave mouse over it (documentation if available, declaration signature if not)

New function "Usage" shows all usages of current symbol through all project sources based on C++ analysis. With virtual methods, it shows all overrides of base class method.

CtrlCore, CtrlLib:

Memory consumption (esp. sizeof) of widgets greatly reduced (by up to 70%).
LabelBox now allows center and right alignment.
Re: 2022.3rc1 [message #59368 is a reply to message #59353] Mon, 19 December 2022 07:47 Go to previous messageGo to next message
coolman is currently offline  coolman
Messages: 114
Registered: April 2006
Location: Czech Republic
Experienced Member
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8
Re: 2022.3rc1 [message #59369 is a reply to message #59368] Mon, 19 December 2022 09:34 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

Does switching off Assist help?

What is your CPU?

Mirek
Re: 2022.3rc1 [message #59370 is a reply to message #59353] Mon, 19 December 2022 09:54 Go to previous messageGo to next message
pvictor is currently offline  pvictor
Messages: 68
Registered: December 2015
Member
Hi,

In the latest version, the Console window remains blank during compilation. Scrollbar moves, Ctrl+A and Ctrl+C allow to extract the text, but the window is empty.

Best regards,
Victor
Re: 2022.3rc1 [message #59371 is a reply to message #59370] Mon, 19 December 2022 10:03 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
pvictor wrote on Mon, 19 December 2022 09:54
Hi,

In the latest version, the Console window remains blank during compilation. Scrollbar moves, Ctrl+A and Ctrl+C allow to extract the text, but the window is empty.

Best regards,
Victor


Care to mention the OS?
Re: 2022.3rc1 [message #59372 is a reply to message #59371] Mon, 19 December 2022 10:08 Go to previous messageGo to next message
pvictor is currently offline  pvictor
Messages: 68
Registered: December 2015
Member
mirek wrote on Mon, 19 December 2022 14:03
pvictor wrote on Mon, 19 December 2022 09:54
Hi,

In the latest version, the Console window remains blank during compilation. Scrollbar moves, Ctrl+A and Ctrl+C allow to extract the text, but the window is empty.

Best regards,
Victor


Care to mention the OS?

Linux Mint 20.3
base: Ubuntu 20.04
Re: 2022.3rc1 [message #59374 is a reply to message #59369] Mon, 19 December 2022 10:22 Go to previous messageGo to next message
Tom1
Messages: 1217
Registered: March 2007
Senior Contributor
Hi Mirek,

I'm now testing and noticed that the compiler messages on console are invisible. Tested with both light and dark theme. I can copy the invisible contents to clipboard though and view them on text editor, so this must be a coloring issue.

Best regards,

Tom

EDIT: I see, I'm not the only one. I'm on Windows 11.

[Updated on: Mon, 19 December 2022 10:24]

Report message to a moderator

Re: 2022.3rc1 [message #59375 is a reply to message #59369] Mon, 19 December 2022 10:32 Go to previous messageGo to next message
coolman is currently offline  coolman
Messages: 114
Registered: April 2006
Location: Czech Republic
Experienced Member
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek
Re: 2022.3rc1 [message #59376 is a reply to message #59370] Mon, 19 December 2022 11:42 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
pvictor wrote on Mon, 19 December 2022 09:54
Hi,

In the latest version, the Console window remains blank during compilation. Scrollbar moves, Ctrl+A and Ctrl+C allow to extract the text, but the window is empty.

Best regards,
Victor


Thank you. Fixed pushed. Will release rc2 in the afternoon.
Re: 2022.3rc1 [message #59377 is a reply to message #59375] Mon, 19 December 2022 11:47 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
coolman wrote on Mon, 19 December 2022 10:32
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek


This is probably Assist indexer overloading your HW. Please try to reduce the number of indexer threads (Setup/Settings/Assist/Number of indexer threads).

Also report what default number do you have there. IMO it should be 10, if there is more, maybe you have tested some time ago and it was left with much higher number.

(Default settings are in ClangConfigSetDefaults, currently I set indexer threads at CPU threads - 2). Maybe this need finetuning.
Re: 2022.3rc1 [message #59379 is a reply to message #59377] Mon, 19 December 2022 17:31 Go to previous messageGo to next message
coolman is currently offline  coolman
Messages: 114
Registered: April 2006
Location: Czech Republic
Experienced Member
mirek wrote on Mon, 19 December 2022 11:47
coolman wrote on Mon, 19 December 2022 10:32
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek


This is probably Assist indexer overloading your HW. Please try to reduce the number of indexer threads (Setup/Settings/Assist/Number of indexer threads).

Also report what default number do you have there. IMO it should be 10, if there is more, maybe you have tested some time ago and it was left with much higher number.

(Default settings are in ClangConfigSetDefaults, currently I set indexer threads at CPU threads - 2). Maybe this need finetuning.


10 indexing threads were set up.
I tried reduce the number of indexer threads but after a while, the behaviour described above returned again. I monitored the running of the IDE using htop and noticed that occasionally a thread consumed more percent of the processor it was assigned to when I was typing. When I tried to double-click, the main IDE thread was consuming up to 18 percent of CPU and still the word was not highlighted.

What confuses me is that I can see a lot of threads assigned to the main process. And the number of threads is equal to 2x the number of CPU cores. The current output from pstree is when 4 of indexing threads was set. But it doesn't matter how many indexing threads is set up, the output is still the same.
pstree -tpch 121637
ide(121637)─┬─{dconf worker}(121639)
            ├─{gdbus}(121640)
            ├─{gmain}(121638)
            ├─{ide}(121642)
            ├─{ide}(121643)
            ├─{ide}(121644)
            ├─{ide}(121645)
            ├─{ide}(121646)
            ├─{ide}(121647)
            ├─{ide}(121648)
            ├─{ide}(121649)
            ├─{ide}(121650)
            ├─{ide}(121651)
            ├─{ide}(121652)
            ├─{ide}(121653)
            ├─{ide}(121654)
            ├─{ide}(121655)
            ├─{ide}(121736)
            ├─{ide}(121737)
            ├─{ide}(121738)
            ├─{ide}(121739)
            ├─{ide}(121740)
            ├─{ide}(121784)
            └─{threaded-ml}(121666)



Edited:
While editing I noticed that a single thread can use up to 60% of the dedicated CPU while the main thread uses up to 80% of the allocated CPU.

[Updated on: Mon, 19 December 2022 17:57]

Report message to a moderator

Re: 2022.3rc1 [message #59381 is a reply to message #59379] Mon, 19 December 2022 18:22 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
coolman wrote on Mon, 19 December 2022 17:31
mirek wrote on Mon, 19 December 2022 11:47
coolman wrote on Mon, 19 December 2022 10:32
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek


This is probably Assist indexer overloading your HW. Please try to reduce the number of indexer threads (Setup/Settings/Assist/Number of indexer threads).

Also report what default number do you have there. IMO it should be 10, if there is more, maybe you have tested some time ago and it was left with much higher number.

(Default settings are in ClangConfigSetDefaults, currently I set indexer threads at CPU threads - 2). Maybe this need finetuning.


10 indexing threads were set up.
I tried reduce the number of indexer threads but after a while, the behaviour described above returned again. I monitored the running of the IDE using htop and noticed that occasionally a thread consumed more percent of the processor it was assigned to when I was typing. When I tried to double-click, the main IDE thread was consuming up to 18 percent of CPU and still the word was not highlighted.

What confuses me is that I can see a lot of threads assigned to the main process. And the number of threads is equal to 2x the number of CPU cores. The current output from pstree is when 4 of indexing threads was set. But it doesn't matter how many indexing threads is set up, the output is still the same.
pstree -tpch 121637
ide(121637)─┬─{dconf worker}(121639)
            ├─{gdbus}(121640)
            ├─{gmain}(121638)
            ├─{ide}(121642)
            ├─{ide}(121643)
            ├─{ide}(121644)
            ├─{ide}(121645)
            ├─{ide}(121646)
            ├─{ide}(121647)
            ├─{ide}(121648)
            ├─{ide}(121649)
            ├─{ide}(121650)
            ├─{ide}(121651)
            ├─{ide}(121652)
            ├─{ide}(121653)
            ├─{ide}(121654)
            ├─{ide}(121655)
            ├─{ide}(121736)
            ├─{ide}(121737)
            ├─{ide}(121738)
            ├─{ide}(121739)
            ├─{ide}(121740)
            ├─{ide}(121784)
            └─{threaded-ml}(121666)



Edited:
While editing I noticed that a single thread can use up to 60% of the dedicated CPU while the main thread uses up to 80% of the allocated CPU.


What if you switch assist off completely? (Just to find out where to look next, is that Assist related or not...) (Do not forget to restart theide)

(Those threads are fine - those are CoWork worker threads, there should be 14 of them. Most of time they are just waiting).

Mirek
Re: 2022.3rc1 [message #59384 is a reply to message #59381] Mon, 19 December 2022 19:25 Go to previous messageGo to next message
coolman is currently offline  coolman
Messages: 114
Registered: April 2006
Location: Czech Republic
Experienced Member
mirek wrote on Mon, 19 December 2022 18:22
coolman wrote on Mon, 19 December 2022 17:31
mirek wrote on Mon, 19 December 2022 11:47
coolman wrote on Mon, 19 December 2022 10:32
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek


This is probably Assist indexer overloading your HW. Please try to reduce the number of indexer threads (Setup/Settings/Assist/Number of indexer threads).

Also report what default number do you have there. IMO it should be 10, if there is more, maybe you have tested some time ago and it was left with much higher number.

(Default settings are in ClangConfigSetDefaults, currently I set indexer threads at CPU threads - 2). Maybe this need finetuning.


10 indexing threads were set up.
I tried reduce the number of indexer threads but after a while, the behaviour described above returned again. I monitored the running of the IDE using htop and noticed that occasionally a thread consumed more percent of the processor it was assigned to when I was typing. When I tried to double-click, the main IDE thread was consuming up to 18 percent of CPU and still the word was not highlighted.

What confuses me is that I can see a lot of threads assigned to the main process. And the number of threads is equal to 2x the number of CPU cores. The current output from pstree is when 4 of indexing threads was set. But it doesn't matter how many indexing threads is set up, the output is still the same.
pstree -tpch 121637
ide(121637)─┬─{dconf worker}(121639)
            ├─{gdbus}(121640)
            ├─{gmain}(121638)
            ├─{ide}(121642)
            ├─{ide}(121643)
            ├─{ide}(121644)
            ├─{ide}(121645)
            ├─{ide}(121646)
            ├─{ide}(121647)
            ├─{ide}(121648)
            ├─{ide}(121649)
            ├─{ide}(121650)
            ├─{ide}(121651)
            ├─{ide}(121652)
            ├─{ide}(121653)
            ├─{ide}(121654)
            ├─{ide}(121655)
            ├─{ide}(121736)
            ├─{ide}(121737)
            ├─{ide}(121738)
            ├─{ide}(121739)
            ├─{ide}(121740)
            ├─{ide}(121784)
            └─{threaded-ml}(121666)



Edited:
While editing I noticed that a single thread can use up to 60% of the dedicated CPU while the main thread uses up to 80% of the allocated CPU.


What if you switch assist off completely? (Just to find out where to look next, is that Assist related or not...) (Do not forget to restart theide)

(Those threads are fine - those are CoWork worker threads, there should be 14 of them. Most of time they are just waiting).

Mirek


When asssist is turned off, the problems do not appear. And the main thread consumes around 20% of CPU.

Radek
Re: 2022.3rc1 [message #59393 is a reply to message #59384] Tue, 20 December 2022 11:10 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
coolman wrote on Mon, 19 December 2022 19:25
mirek wrote on Mon, 19 December 2022 18:22
coolman wrote on Mon, 19 December 2022 17:31
mirek wrote on Mon, 19 December 2022 11:47
coolman wrote on Mon, 19 December 2022 10:32
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek


This is probably Assist indexer overloading your HW. Please try to reduce the number of indexer threads (Setup/Settings/Assist/Number of indexer threads).

Also report what default number do you have there. IMO it should be 10, if there is more, maybe you have tested some time ago and it was left with much higher number.

(Default settings are in ClangConfigSetDefaults, currently I set indexer threads at CPU threads - 2). Maybe this need finetuning.


10 indexing threads were set up.
I tried reduce the number of indexer threads but after a while, the behaviour described above returned again. I monitored the running of the IDE using htop and noticed that occasionally a thread consumed more percent of the processor it was assigned to when I was typing. When I tried to double-click, the main IDE thread was consuming up to 18 percent of CPU and still the word was not highlighted.

What confuses me is that I can see a lot of threads assigned to the main process. And the number of threads is equal to 2x the number of CPU cores. The current output from pstree is when 4 of indexing threads was set. But it doesn't matter how many indexing threads is set up, the output is still the same.
pstree -tpch 121637
ide(121637)─┬─{dconf worker}(121639)
            ├─{gdbus}(121640)
            ├─{gmain}(121638)
            ├─{ide}(121642)
            ├─{ide}(121643)
            ├─{ide}(121644)
            ├─{ide}(121645)
            ├─{ide}(121646)
            ├─{ide}(121647)
            ├─{ide}(121648)
            ├─{ide}(121649)
            ├─{ide}(121650)
            ├─{ide}(121651)
            ├─{ide}(121652)
            ├─{ide}(121653)
            ├─{ide}(121654)
            ├─{ide}(121655)
            ├─{ide}(121736)
            ├─{ide}(121737)
            ├─{ide}(121738)
            ├─{ide}(121739)
            ├─{ide}(121740)
            ├─{ide}(121784)
            └─{threaded-ml}(121666)



Edited:
While editing I noticed that a single thread can use up to 60% of the dedicated CPU while the main thread uses up to 80% of the allocated CPU.


What if you switch assist off completely? (Just to find out where to look next, is that Assist related or not...) (Do not forget to restart theide)

(Those threads are fine - those are CoWork worker threads, there should be 14 of them. Most of time they are just waiting).

Mirek


When asssist is turned off, the problems do not appear. And the main thread consumes around 20% of CPU.

Radek


What about leaving Assist on and disabling "Indexer gets invoked automatically" (and restarting).

Also, is it a problem even with 1 indexer thread?

How much RAM do you have?

(For reference, I am testing with 2400G (4C/8T) with 8GB RAM, Ubuntu 20.04. Assist feels slower than my Win machine (5950x), but no symptoms as you describe. So I am puzzled).
Re: 2022.3rc1 [message #59396 is a reply to message #59393] Tue, 20 December 2022 18:09 Go to previous messageGo to next message
coolman is currently offline  coolman
Messages: 114
Registered: April 2006
Location: Czech Republic
Experienced Member
mirek wrote on Tue, 20 December 2022 11:10
coolman wrote on Mon, 19 December 2022 19:25
mirek wrote on Mon, 19 December 2022 18:22
coolman wrote on Mon, 19 December 2022 17:31
mirek wrote on Mon, 19 December 2022 11:47
coolman wrote on Mon, 19 December 2022 10:32
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek


This is probably Assist indexer overloading your HW. Please try to reduce the number of indexer threads (Setup/Settings/Assist/Number of indexer threads).

Also report what default number do you have there. IMO it should be 10, if there is more, maybe you have tested some time ago and it was left with much higher number.

(Default settings are in ClangConfigSetDefaults, currently I set indexer threads at CPU threads - 2). Maybe this need finetuning.


10 indexing threads were set up.
I tried reduce the number of indexer threads but after a while, the behaviour described above returned again. I monitored the running of the IDE using htop and noticed that occasionally a thread consumed more percent of the processor it was assigned to when I was typing. When I tried to double-click, the main IDE thread was consuming up to 18 percent of CPU and still the word was not highlighted.

What confuses me is that I can see a lot of threads assigned to the main process. And the number of threads is equal to 2x the number of CPU cores. The current output from pstree is when 4 of indexing threads was set. But it doesn't matter how many indexing threads is set up, the output is still the same.
pstree -tpch 121637
ide(121637)─┬─{dconf worker}(121639)
            ├─{gdbus}(121640)
            ├─{gmain}(121638)
            ├─{ide}(121642)
            ├─{ide}(121643)
            ├─{ide}(121644)
            ├─{ide}(121645)
            ├─{ide}(121646)
            ├─{ide}(121647)
            ├─{ide}(121648)
            ├─{ide}(121649)
            ├─{ide}(121650)
            ├─{ide}(121651)
            ├─{ide}(121652)
            ├─{ide}(121653)
            ├─{ide}(121654)
            ├─{ide}(121655)
            ├─{ide}(121736)
            ├─{ide}(121737)
            ├─{ide}(121738)
            ├─{ide}(121739)
            ├─{ide}(121740)
            ├─{ide}(121784)
            └─{threaded-ml}(121666)



Edited:
While editing I noticed that a single thread can use up to 60% of the dedicated CPU while the main thread uses up to 80% of the allocated CPU.


What if you switch assist off completely? (Just to find out where to look next, is that Assist related or not...) (Do not forget to restart theide)

(Those threads are fine - those are CoWork worker threads, there should be 14 of them. Most of time they are just waiting).

Mirek


When asssist is turned off, the problems do not appear. And the main thread consumes around 20% of CPU.

Radek


What about leaving Assist on and disabling "Indexer gets invoked automatically" (and restarting).

If the option "Indexer gets invoked automatically" is turned off, the mentioned errors appear less often, but they are still there.

Quote:

Also, is it a problem even with 1 indexer thread?

The mentioned errors appear less often, but they are still there too.

Quote:

How much RAM do you have?

I have got 32GB RAM.

Quote:

(For reference, I am testing with 2400G (4C/8T) with 8GB RAM, Ubuntu 20.04. Assist feels slower than my Win machine (5950x), but no symptoms as you describe. So I am puzzled).

I don't know how long you've been writing the code under Linux testing, but mentioned problems show up after some time of editing the code. And I always have more than three files open. And I have two IDE opened. One with the IDE code and the second is openned from the first one with a different project.
Re: 2022.3rc1 [message #59398 is a reply to message #59396] Wed, 21 December 2022 18:41 Go to previous messageGo to next message
coolman is currently offline  coolman
Messages: 114
Registered: April 2006
Location: Czech Republic
Experienced Member
coolman wrote on Tue, 20 December 2022 18:09
mirek wrote on Tue, 20 December 2022 11:10
coolman wrote on Mon, 19 December 2022 19:25
mirek wrote on Mon, 19 December 2022 18:22
coolman wrote on Mon, 19 December 2022 17:31
mirek wrote on Mon, 19 December 2022 11:47
coolman wrote on Mon, 19 December 2022 10:32
mirek wrote on Mon, 19 December 2022 09:34
coolman wrote on Mon, 19 December 2022 07:47
Hi Mirek,

I've been testing latest version master version from the GitHub and I really don't like the behaviour of the IDE when editing the file.
- I mean the cursor getting stuck while typing, when the delay between pressing a key and then writing a character is too long.
- Also, double clicking on a word to highlight the word does not work properly. I have to try double clicking multiple times with different speeds to get this feature to work at all.

OS: Ubuntu 20.04
Linux 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu clang version 13.0.1-++20220120110924+75e33f71c2da-1~exp1~20220120231001.5 8


Is this specific for the latest version? (If not, why are your reporting this now ? Smile

I started regularly using the latest version of the IDE after the Alt+J fix.

Quote:

Does switching off Assist help?

Yes it can help.

Quote:

What is your CPU?

cat /proc/cpuinfo
vendor_id : GenuineIntel
cpu family : 6
model : 165
model name : Intel(R) Core(TM) i7-10850H CPU @ 2.70GHz
stepping : 2
microcode : 0xf0
cpu MHz : 2700.000
cache size : 12288 KB
physical id : 0
siblings : 12
...

BR, Radek


This is probably Assist indexer overloading your HW. Please try to reduce the number of indexer threads (Setup/Settings/Assist/Number of indexer threads).

Also report what default number do you have there. IMO it should be 10, if there is more, maybe you have tested some time ago and it was left with much higher number.

(Default settings are in ClangConfigSetDefaults, currently I set indexer threads at CPU threads - 2). Maybe this need finetuning.


10 indexing threads were set up.
I tried reduce the number of indexer threads but after a while, the behaviour described above returned again. I monitored the running of the IDE using htop and noticed that occasionally a thread consumed more percent of the processor it was assigned to when I was typing. When I tried to double-click, the main IDE thread was consuming up to 18 percent of CPU and still the word was not highlighted.

What confuses me is that I can see a lot of threads assigned to the main process. And the number of threads is equal to 2x the number of CPU cores. The current output from pstree is when 4 of indexing threads was set. But it doesn't matter how many indexing threads is set up, the output is still the same.
pstree -tpch 121637
ide(121637)─┬─{dconf worker}(121639)
            ├─{gdbus}(121640)
            ├─{gmain}(121638)
            ├─{ide}(121642)
            ├─{ide}(121643)
            ├─{ide}(121644)
            ├─{ide}(121645)
            ├─{ide}(121646)
            ├─{ide}(121647)
            ├─{ide}(121648)
            ├─{ide}(121649)
            ├─{ide}(121650)
            ├─{ide}(121651)
            ├─{ide}(121652)
            ├─{ide}(121653)
            ├─{ide}(121654)
            ├─{ide}(121655)
            ├─{ide}(121736)
            ├─{ide}(121737)
            ├─{ide}(121738)
            ├─{ide}(121739)
            ├─{ide}(121740)
            ├─{ide}(121784)
            └─{threaded-ml}(121666)



Edited:
While editing I noticed that a single thread can use up to 60% of the dedicated CPU while the main thread uses up to 80% of the allocated CPU.


What if you switch assist off completely? (Just to find out where to look next, is that Assist related or not...) (Do not forget to restart theide)

(Those threads are fine - those are CoWork worker threads, there should be 14 of them. Most of time they are just waiting).

Mirek


When asssist is turned off, the problems do not appear. And the main thread consumes around 20% of CPU.

Radek


What about leaving Assist on and disabling "Indexer gets invoked automatically" (and restarting).

If the option "Indexer gets invoked automatically" is turned off, the mentioned errors appear less often, but they are still there.

Quote:

Also, is it a problem even with 1 indexer thread?

The mentioned errors appear less often, but they are still there too.

Quote:

How much RAM do you have?

I have got 32GB RAM.

Quote:

(For reference, I am testing with 2400G (4C/8T) with 8GB RAM, Ubuntu 20.04. Assist feels slower than my Win machine (5950x), but no symptoms as you describe. So I am puzzled).

I don't know how long you've been writing the code under Linux testing, but mentioned problems show up after some time of editing the code. And I always have more than three files open. And I have two IDE opened. One with the IDE code and the second is openned from the first one with a different project.

It works correctly with the latest changes.. Thank you
Re: 2022.3rc1 [message #59405 is a reply to message #59398] Thu, 22 December 2022 14:22 Go to previous messageGo to next message
BioBytes is currently offline  BioBytes
Messages: 307
Registered: October 2008
Location: France
Senior Member
Hi,

The Console window still remains blank during compilation when choosing Dark IDE. Sad

Good day

Regards
Biobytes
Re: 2022.3rc1 [message #59406 is a reply to message #59405] Thu, 22 December 2022 15:31 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
BioBytes wrote on Thu, 22 December 2022 14:22
Hi,

The Console window still remains blank during compilation when choosing Dark IDE. Sad

Good day

Regards
Biobytes


Details please. For the record, I have just tested in Win32.
Re: 2022.3rc1 [message #59407 is a reply to message #59406] Thu, 22 December 2022 17:05 Go to previous messageGo to next message
Tom1
Messages: 1217
Registered: March 2007
Senior Contributor
Hi,

Just checked, and Windows is working fine with Dark theme. However, selecting IDE settings GUI theme = Dark, results in very dark console text on pretty black paper in Linux. (At least on my Linux Mint 21.1.) When GUI theme = Host platform in Linux, and the host platform theme is dark, the console looks good.

Best regards,

Tom

EDIT: BTW, in Windows 11 the Dark theme (host platform) drop down menu item texts now appear with black text and gray selection bar, which is hard to read. The white text and gray selection bar in the previous release was better. However, the light theme is now better than in the previous release (2022.2) on Windows 11, since the contrast of menu text and selection bar is better.

[Updated on: Thu, 22 December 2022 17:15]

Report message to a moderator

Re: 2022.3rc1 [message #59436 is a reply to message #59405] Tue, 27 December 2022 09:49 Go to previous message
BioBytes is currently offline  BioBytes
Messages: 307
Registered: October 2008
Location: France
Senior Member
Hi,


Quote:


The Console window still remains blank during compilation when choosing Dark IDE.


Solved with 16651 Smile
Many thanks
Biobytes
Previous Topic: Merry Christmas and Happy New Year 2023!
Next Topic: 2022.3
Goto Forum:
  


Current Time: Mon Jun 24 06:34:48 CEST 2024

Total time taken to generate the page: 0.01781 seconds