Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Layout (Forms) Designer » layout file not updated by 608-dev2
layout file not updated by 608-dev2 [message #5141] Thu, 07 September 2006 10:19 Go to next message
forlano is currently offline  forlano
Messages: 1189
Registered: March 2006
Location: Italy
Senior Contributor
Hello,

I'm observing a strange behaviour. Before 608-dev2 each time I touched a ctrl on the layout file of designer all the package was compiled entirely. Now this doesn't happen. Not only, but the modification I do in the layout have no effect after the compilation (really no compilation because only the linking precedure is performed). It is like is I've not modified the layout or the save procedure of layout is not really done.

I tried to recompile the whole package and the whole library but nothing change. Am I the only who has this problem?

Luigi

EDIT: the modified layout file is saved but the package is not aware of it.

[Updated on: Thu, 07 September 2006 10:22]

Report message to a moderator

Re: layout file not updated by 608-dev2 [message #5146 is a reply to message #5141] Thu, 07 September 2006 23:15 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13984
Registered: November 2005
Ultimate Member
I have not encountered this problem yet.

However, recompile tests here are performed based on include file dependencies - TheIDE keeps track about what includes what by parsing .cpp and .h files. Is not there something special about your .lay include?

Mirek
Re: layout file not updated by 608-dev2 [message #5147 is a reply to message #5146] Thu, 07 September 2006 23:50 Go to previous message
forlano is currently offline  forlano
Messages: 1189
Registered: March 2006
Location: Italy
Senior Contributor
luzr wrote on Thu, 07 September 2006 23:15

I have not encountered this problem yet.

However, recompile tests here are performed based on include file dependencies - TheIDE keeps track about what includes what by parsing .cpp and .h files. Is not there something special about your .lay include?

Mirek


Yes, very special indeed. Now it works.
The last time I've tried to do a new version from the old package. Then I started to rename the package folder of the include and by mistake I touched that of the good file.
I think that in order to prevent such situation, when one set a new package all the opened tabs of the old package should be closed. At some moment now I have many tab with the same name and the accident it is easy to happen.

Thank you,
Luigi

[Updated on: Fri, 08 September 2006 00:01]

Report message to a moderator

Previous Topic: wrong layout dimensioning under X11
Next Topic: 609-Dev3 - no layout designer?
Goto Forum:
  


Current Time: Thu Jun 13 00:56:41 CEST 2024

Total time taken to generate the page: 0.02426 seconds