Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » Draw, Display, Images, Bitmaps, Icons » How to NOT dlopen libgtk and stuff....?
How to NOT dlopen libgtk and stuff....? [message #7149] Fri, 15 December 2006 20:17 Go to next message
rockpiper is currently offline  rockpiper
Messages: 1
Registered: December 2006
Junior Member
Somewhere between 605 and 612 you seem to have switched from drawing your own widgets to “dlopening” libgtk or something (at least on UN*X systems, didn't check Windows). Though this is nice for a better desktop integration for (at least) GNOME users, I'd rather have the old behavior back because it is WAY faster. (I'm talking about seconds of startup time, here)

Is there a way to accomplish this as a runtime or compile time option?

Thanks,
--r.
Re: How to NOT dlopen libgtk and stuff....? [message #7179 is a reply to message #7149] Sun, 17 December 2006 17:42 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13849
Registered: November 2005
Ultimate Member
rockpiper wrote on Fri, 15 December 2006 14:17

Somewhere between 605 and 612 you seem to have switched from drawing your own widgets to “dlopening” libgtk or something (at least on UN*X systems, didn't check Windows). Though this is nice for a better desktop integration for (at least) GNOME users, I'd rather have the old behavior back because it is WAY faster. (I'm talking about seconds of startup time, here)



Interesting, I have not noticed such difference. Maybe I should check better. What is your hardware / distro? Have you checked the release mode?

Quote:


Is there a way to accomplish this as a runtime or compile time option?



You can get old look&feel, but dlopen is performed anyway, so that is no win...

I have no problem with adding the flag, but I would like to investigate this issue first. IME, the startup time difference is negligible. What can be wrong?

Actually, thinking about it, it is also possible that some other issue included on the way is causing the difference.

Mirek
Re: How to NOT dlopen libgtk and stuff....? [message #7180 is a reply to message #7179] Sun, 17 December 2006 18:50 Go to previous message
mirek is currently offline  mirek
Messages: 13849
Registered: November 2005
Ultimate Member
First preliminary test

void InitX11Draw(const char *dispname)
{
	TimeStop tm;
	if(GTK() && GDK() && GOBJ()) {
		LOG("GTK load " << tm.Elapsed() << " ms");


shows GTK load time 5ms. Startup is immediate (Ubuntu AMD64, AMD 2.4Ghz)
Can you check the same?

(Draw/DrawX11.cpp 241)

Mirek
Previous Topic: DrawPolygon in PDF bug
Next Topic: Drawing Backgroud
Goto Forum:
  


Current Time: Sat Mar 25 09:47:21 CET 2023

Total time taken to generate the page: 0.01434 seconds