Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Problems installing in Ubuntu 6.06
Problems installing in Ubuntu 6.06 [message #7715] Tue, 16 January 2007 23:09 Go to next message
negroheider is currently offline  negroheider
Messages: 2
Registered: January 2007
Junior Member
Hey everyone,

It's been a while since I've worked in Linux, and I found some good comments on this IDE on the web. I've been trying to compile it in Ubuntu 6.06 but I've hit a couple of problems. First I had to edit the Makefile's first line to make it read this:

UPPDIR1 = ./upp/uppsrc/

Else it wouldn't start compiling. Next I got this error message:

In file included from /usr/include/X11/Xft/Xft.h:41,
from ./upp/uppsrc/Draw/Draw.h:24,
from ./upp/uppsrc/CtrlCore/CtrlCore.h:4,
from ./upp/uppsrc/CtrlLib/CtrlLib.h:4,
from ./upp/uppsrc/ide/Common/Common.h:4,
from ./upp/uppsrc/ide/ide.h:4,
from ./upp/uppsrc/ide/SelectPkg.cpp:1:
/usr/include/ft2build.h:56:38: error: freetype/config/ftheader.h: No such file or directory


and a couple others. As far as I understand, I'm missing some linking to some package, but if I run

aptitude search freetype

I get the following output:

v freetype-tools
p freetype1-tools
i freetype2
p freetype2-demos
v freetype2-dev
i libfreetype6
i libfreetype6-dev

Now correct me here, I have the freetype package installed, right? Any idea what I'm missing?
Re: Problems installing in Ubuntu 6.06 [message #7717 is a reply to message #7715] Tue, 16 January 2007 23:25 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12122
Registered: November 2005
Ultimate Member
What is the U++ version?

In the recent 4 months or so, development version are released as .deb packages specifically build for Ubuntu..

Mirek
Re: Problems installing in Ubuntu 6.06 [message #7718 is a reply to message #7715] Tue, 16 January 2007 23:29 Go to previous messageGo to next message
zsolt is currently offline  zsolt
Messages: 600
Registered: December 2005
Location: Budapest, Hungary
Contributor
Which upp version you want to compile?
BTW, linux binary version of upp-605 runs without any problems on my Ubuntu 606. You can try compiling dev versions with that TheIDE.
Or you can use binary .deb packages.

I think, Makefiles are just for situations when you can not start TheIDE binary.
Re: Problems installing in Ubuntu 6.06 [message #7729 is a reply to message #7715] Wed, 17 January 2007 16:02 Go to previous messageGo to next message
negroheider is currently offline  negroheider
Messages: 2
Registered: January 2007
Junior Member
All right, I finally figured out how to compile it. I was obviously missing the path to the mentioned file, so I edited the 3rd line of the Makefile, which originally read:

CINC = -I$(UPPDIR1)

so that it said:

CINC = -I$(UPPDIR1) -I/usr/include/freetype2/

That was enough to make it work.

BTW, I was compiling the 605 version.


Re: Problems installing in Ubuntu 6.06 [message #7730 is a reply to message #7729] Wed, 17 January 2007 19:17 Go to previous message
mirek is currently offline  mirek
Messages: 12122
Registered: November 2005
Ultimate Member
negroheider wrote on Wed, 17 January 2007 10:02


BTW, I was compiling the 605 version.



That is sort of off-topic now Wink

Since then, Linux releases improved 200%.

Mirek
Previous Topic: Uninstall doesn't remove the upp directory
Next Topic: Look of the IDE on kubuntu 6.10
Goto Forum:
  


Current Time: Mon Dec 09 10:09:25 CET 2019

Total time taken to generate the page: 0.01301 seconds