Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » "cannot find lgtk-x11-2.0" under gentoo linux
"cannot find lgtk-x11-2.0" under gentoo linux [message #13072] Sat, 08 December 2007 21:55 Go to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
Hi everyone,

I'm stuck on a quite strange problem. I'm not sure where exactly to check and so far I've not understood why it happens.

When I try to build theide (current svn trunk), I get the following error:

/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgtk-x11-2.0

To anticipate some questions, I have gtk version 2.12.1-r2 compiled from sources and installed (using emerge). Standalone gtk applications compile fine, I only get this problem under theide. libgtk-x11-2.0.* files and symbolic links are present in
/usr/lib.

/usr/lib is of course present in the library path configuration in theide.

I use theide precompiled from 2007.1 distribution

GCC is version 4.1.2.

Anyone has a clue how to make gcc happy about gtk library finding?

Thank you in advance.
Lionel
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13079 is a reply to message #13072] Sun, 09 December 2007 13:34 Go to previous messageGo to next message
waxblood is currently offline  waxblood
Messages: 95
Registered: January 2007
Member
Don't know the best solution to your problem, but a quick fix could be simply getting rid of gtk libraries:

-Select project->Main package configuration
-Insert and select a line with GUI NOGTK inside it.
-compile, now should work


David
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13084 is a reply to message #13072] Sun, 09 December 2007 19:08 Go to previous messageGo to next message
mr_ped is currently offline  mr_ped
Messages: 801
Registered: November 2005
Location: Czech Republic - Praha
Experienced Contributor

Verbose mode ON
Copy and analyze the linking command of TheIDE.
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13094 is a reply to message #13084] Mon, 10 December 2007 19:40 Go to previous messageGo to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
mr_ped wrote on Sun, 09 December 2007 19:08

Verbose mode ON
Copy and analyze the linking command of TheIDE.


Already done. The command-line is quite large so I'm not sure I should post it, if you want to have a look I will. Here is a summary:

c++ -static -o "/home/lionel/upp/out/GCC.Gui/ide" -Wl,-s L"/usr/lib" -L"/usr/X11R6/lib" -Wl,-O,2  <series_of_files.o> -Wl,--start-group <series_of_files.a> -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lX11 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lX11 -ldl -lXft -lfontconfig -lXrender -lfreetype -lexpat <series_of_files.a> -lpng "/home/lionel/upp/out/plugin/png/GCC.Gui/png.a" -Wl,--end-group
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgtk-x11-2.0
collect2: ld a retourné 1 code d'état d'exécution

Frankly, everything seems to be ok... Where to search next? I suspect the -static to be the cause, but I'm not sure.
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13095 is a reply to message #13079] Mon, 10 December 2007 19:50 Go to previous messageGo to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
waxblood wrote on Sun, 09 December 2007 13:34

Don't know the best solution to your problem, but a quick fix could be simply getting rid of gtk libraries:

-Select project->Main package configuration
-Insert and select a line with GUI NOGTK inside it.
-compile, now should work


David


Hi David, thanks for the tip. I already gave it a try, but I get some undefined references, the first being GetDrapAndDropSource().

Can we get ride of drag-and-drop in theide package ?

Lionel
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13096 is a reply to message #13095] Mon, 10 December 2007 20:59 Go to previous messageGo to next message
waxblood is currently offline  waxblood
Messages: 95
Registered: January 2007
Member
AFAIK you can't drop DnD support, but this seems to be the old X11DnD case mismatch problem, see http://www.ultimatepp.org/forum/index.php?t=msg&goto=121 46&&srch=svn+mismatch#msg_12146



David



Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13097 is a reply to message #13096] Mon, 10 December 2007 21:12 Go to previous messageGo to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
Thanks for this one, I should have searched more. So... after getting rid of this, I... still have undefined references Embarassed.
/usr/lib/libX11.a(ConnDis.o): In function `_X11TransConnectDisplay':
(.text+0xaac): undefined reference to `XauDisposeAuth'
/usr/lib/libX11.a(ConnDis.o): In function `_X11TransConnectDisplay':
(.text+0xe8c): undefined reference to `XauGetBestAuthByAddr'
/usr/lib/libX11.a(ConnDis.o): In function `_X11TransConnectDisplay':
(.text+0x1143): undefined reference to `XdmcpWrap'
/usr/lib/libfontconfig.a(fcxml.o): In function `FcConfigMessage':
(.text+0x5d): undefined reference to `xmlSAX2GetLineNumber'
/usr/lib/libfontconfig.a(fcxml.o): In function `FcConfigMessage':
(.text+0xe5): undefined reference to `xmlSAX2GetLineNumber'
/usr/lib/libfontconfig.a(fcxml.o): In function `FcConfigParseAndLoad':
(.text+0x2a9a): undefined reference to `xmlCreatePushParserCtxt'
/usr/lib/libfontconfig.a(fcxml.o): In function `FcConfigParseAndLoad':
(.text+0x2b1a): undefined reference to `xmlParseChunk'
/usr/lib/libfontconfig.a(fcxml.o): In function `FcConfigParseAndLoad':
(.text+0x2b45): undefined reference to `xmlFreeParserCtxt'
/usr/lib/libfontconfig.a(fcxml.o): In function `FcConfigParseAndLoad':
(.text+0x2e80): undefined reference to `xmlCtxtGetLastError'
collect2: ld a retourné 1 code d'état d'exécution

There were errors. (0:03.29)


I'll try to have a look by myself when I have more time. If someone has a good idea don't hesitate!

Thanks everyone.

Lionel
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13099 is a reply to message #13094] Mon, 10 December 2007 21:58 Go to previous messageGo to next message
mr_ped is currently offline  mr_ped
Messages: 801
Registered: November 2005
Location: Czech Republic - Praha
Experienced Contributor

chickenk wrote on Mon, 10 December 2007 19:40


Already done. The command-line is quite large so I'm not sure I should post it, if you want to have a look I will. Here is a summary:

c++ -static -o "/home/lionel/upp/out/GCC.Gui/ide" -Wl,-s L"/usr/lib" ...




looks to me like the -L"/usr/lib" is missing the minus sign.
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #13292 is a reply to message #13099] Sun, 30 December 2007 02:38 Go to previous messageGo to next message
phirox is currently offline  phirox
Messages: 49
Registered: December 2007
Member
I had the same problem, what helped for me was to compile it non-static. So remove the '-static' in the makefile or change the settings in the building options of theide.
Re: "cannot find lgtk-x11-2.0" under gentoo linux [message #15211 is a reply to message #13292] Wed, 09 April 2008 22:10 Go to previous message
fithisux is currently offline  fithisux
Messages: 12
Registered: January 2007
Promising Member
In 2008Beta2 changing to all shared and creating a makefile still has static instead of shared. the problem happens under FC8 x86. In 2007.1 on my WINXP/32bit laptop the problem does not appear.

[Updated on: Wed, 09 April 2008 22:23]

Report message to a moderator

Previous Topic: Build error: PIC register ‘%ebx’ clobbered in ‘asm’
Next Topic: how to configure MSC9?
Goto Forum:
  


Current Time: Sat Dec 07 13:20:59 CET 2019

Total time taken to generate the page: 0.01390 seconds