Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » Slider&ProgressIndicator » Problem with ProgressIndicator in Kubuntu Linux
Problem with ProgressIndicator in Kubuntu Linux [message #14728] Tue, 11 March 2008 12:38 Go to next message
Tom1
Messages: 612
Registered: March 2007
Contributor
Hi,

I do not seem to get ProgressIndicator to work in Kubuntu Linux. The progress remains in zero position no matter what. In windows everything works OK with the same simple code.

progress1.Set(1,2);

// Tom
Re: Problem with ProgressIndicator in Kubuntu Linux [message #14730 is a reply to message #14728] Tue, 11 March 2008 16:04 Go to previous messageGo to next message
Tom1
Messages: 612
Registered: March 2007
Contributor
More on this: The ProgressIndicator starts working OK if ProgressIndicator::Percent(true); is called to enable viewing of percentage of total completed.

I guess this should be looked at by somebody who knows about the internals, but for me this is not a high priority issue as I can accept having the percentage value visible.

// Tom
Re: Problem with ProgressIndicator in Kubuntu Linux [message #14745 is a reply to message #14730] Wed, 12 March 2008 14:39 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11844
Registered: November 2005
Ultimate Member
Tom1 wrote on Tue, 11 March 2008 11:04

More on this: The ProgressIndicator starts working OK if ProgressIndicator::Percent(true); is called to enable viewing of percentage of total completed.

I guess this should be looked at by somebody who knows about the internals, but for me this is not a high priority issue as I can accept having the percentage value visible.

// Tom


Can you post a testcase? E.g. in theide, it seems to work.

Requires more investigation.

Mirek
Re: Problem with ProgressIndicator in Kubuntu Linux [message #14758 is a reply to message #14745] Thu, 13 March 2008 10:42 Go to previous messageGo to next message
Tom1
Messages: 612
Registered: March 2007
Contributor
Actually it does not work on theide either. After selecting the main package there is e.g. Assist++ progress dialog which updates normally on windows but not on kubuntu 7.10.

I did some testing and noticed that changing the KDE System Settings / Appearance / GTK Styles from "Use my KDE style in GTK applications" to "Use another style: Raleigh" makes the progress bar to work again. Also the previously blank drop list buttons and scroll bar buttons become visible again. So, I think this is all about handling the situation when the GTK style is not recognized.

// Tom
Re: Problem with ProgressIndicator in Kubuntu Linux [message #14806 is a reply to message #14758] Sat, 15 March 2008 15:14 Go to previous message
mirek is currently offline  mirek
Messages: 11844
Registered: November 2005
Ultimate Member
Tom1 wrote on Thu, 13 March 2008 05:42

Actually it does not work on theide either. After selecting the main package there is e.g. Assist++ progress dialog which updates normally on windows but not on kubuntu 7.10.

I did some testing and noticed that changing the KDE System Settings / Appearance / GTK Styles from "Use my KDE style in GTK applications" to "Use another style: Raleigh" makes the progress bar to work again. Also the previously blank drop list buttons and scroll bar buttons become visible again. So, I think this is all about handling the situation when the GTK style is not recognized.

// Tom


OK, looks like we have a new issue, because Kubuntu chameleon problems were reported by James too... Sad

Mirek
Previous Topic: ProgressIndicator in ArrayCtrl
Next Topic: SliderCtrl IsVert() not public?
Goto Forum:
  


Current Time: Thu Apr 25 10:39:38 CEST 2019

Total time taken to generate the page: 0.01327 seconds