Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Using SVN from U++
Using SVN from U++ [message #21749] Wed, 03 June 2009 16:50 Go to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
I read somewhere that theide supports SVN? I have a project that I checked out from SVN then placed into the MyApps directory. The context menu on a given file in the project shows an option "Show svn history for file" which works, however, I was wondering if that is all the IDE does? i.e. can I do commits? Check the status of what has changed, etc... ?

Thanks,

Jeremy
Re: Using SVN from U++ [message #21836 is a reply to message #21749] Sun, 07 June 2009 23:53 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
jeremy_c wrote on Wed, 03 June 2009 10:50

I read somewhere that theide supports SVN? I have a project that I checked out from SVN then placed into the MyApps directory. The context menu on a given file in the project shows an option "Show svn history for file" which works, however, I was wondering if that is all the IDE does? i.e. can I do commits? Check the status of what has changed, etc... ?

Thanks,

Jeremy



I think, based on your other post, that you have already found the answer Smile

Yes, it is able to "Sync", which is automated mix of several actions, which basically puts your source tree in sync with repo.

Mirek
Re: Using SVN from U++ [message #27645 is a reply to message #21749] Tue, 27 July 2010 17:17 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
This is silly but I'm having problems with this again. How do I commit my code from the ide?

Jeremy
Re: Using SVN from U++ [message #27647 is a reply to message #27645] Tue, 27 July 2010 17:57 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

jeremy_c wrote on Tue, 27 July 2010 17:17

This is silly but I'm having problems with this again. How do I commit my code from the ide?

Jeremy


Hi Jeremy,

The syncing options should be in Edit > SVN submenu. Similar options are present in the context menu that appears when you right click on file or package on the left side of theide:
index.php?t=getfile&id=2683&private=0

It should open a window with list of changed files and, most importantly, commit button.

If you don't see these options or the window doesn't appear, it is either problem with you svn installation (but then neither the svn history would work, so it is probably not the case) or it might be a bug.

Maybe you could try the standalone usvn client. It is in uppsrc, just compile it and run in your working copy directory. It is the same code as in theide, so if there is some problem in the code, it should be broken too and possibly easier to debug.

Best regards,
Honza
  • Attachment: svn.png
    (Size: 142.94KB, Downloaded 438 times)
Re: Using SVN from U++ [message #27648 is a reply to message #27647] Tue, 27 July 2010 18:12 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
dolik.rce wrote on Tue, 27 July 2010 11:57


If you don't see these options or the window doesn't appear, it is either problem with you svn installation (but then neither the svn history would work, so it is probably not the case) or it might be a bug.



The history works fine. None of the context menus have the SVN menu. From the command shell (cmd.exe) the "svn" command works fine and that's what I've been using for a very long time, but I decided to get back to using the IDE for SVN commits because it is much easier/nicer. I just couldn't find it again.

dolik.rce wrote on Tue, 27 July 2010 11:57


Maybe you could try the standalone usvn client. It is in uppsrc, just compile it and run in your working copy directory. It is the same code as in theide, so if there is some problem in the code, it should be broken too and possibly easier to debug.



The gui works fine.

index.php?t=getfile&id=2684&private=0

Any thoughts on where to go from here?

Jeremy
  • Attachment: usvn.png
    (Size: 374.46KB, Downloaded 429 times)
Re: Using SVN from U++ [message #27649 is a reply to message #21749] Tue, 27 July 2010 18:15 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
Oh, I am using upp 2467.

Jeremy
Re: Using SVN from U++ [message #27652 is a reply to message #27648] Tue, 27 July 2010 19:41 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

Some time ago I run into similar problem, but I was not able to reproduce it... until now Smile The troubles are caused by the design flaw in theide. The syncing options don't show up when at least one of the nests is not svn working copy.

I enclose the patched files form uppsrc/ide, you can try to recompile theide and test it. If Mirek agrees, I'll commit the changes ASAP.

Best regards,
Honza
Re: Using SVN from U++ [message #27653 is a reply to message #27652] Tue, 27 July 2010 20:34 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
dolik.rce wrote on Tue, 27 July 2010 13:41

Some time ago I run into similar problem, but I was not able to reproduce it... until now Smile The troubles are caused by the design flaw in theide. The syncing options don't show up when at least one of the nests is not svn working copy.

I enclose the patched files form uppsrc/ide, you can try to recompile theide and test it. If Mirek agrees, I'll commit the changes ASAP.



I copied your two source files into my uppsrc/ide directory and the SVN menu now appears. Running the old ide.exe the SVN menu does not appear. So, this did fix my problem at least. Thank you!

Jeremy

[Updated on: Tue, 27 July 2010 20:34]

Report message to a moderator

Re: Using SVN from U++ [message #27770 is a reply to message #21749] Tue, 03 August 2010 04:52 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
Any thoughts on this bug and fix?

Jeremy
Re: Using SVN from U++ [message #27772 is a reply to message #27770] Tue, 03 August 2010 08:49 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

jeremy_c wrote on Tue, 03 August 2010 04:52

Any thoughts on this bug and fix?

Jeremy

Hi Jeremy,
Sorry it takes so long. I don't have the commit rights for usvn directory and Mirek seems to be on holiday or somewhere.

Maybe anyone else from the devs who has the rights?

Honza
Re: Using SVN from U++ [message #27776 is a reply to message #27772] Tue, 03 August 2010 10:51 Go to previous messageGo to next message
andrei_natanael is currently offline  andrei_natanael
Messages: 262
Registered: January 2009
Experienced Member
Hello,

Fix committed. I hope everything is fine now.

Andrei
Re: Using SVN from U++ [message #27802 is a reply to message #27776] Wed, 04 August 2010 11:42 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

andrei_natanael wrote on Tue, 03 August 2010 10:51

Hello,

Fix committed. I hope everything is fine now.

Andrei

Thank you Andrei.
Honza
Re: Using SVN from U++ [message #27804 is a reply to message #27776] Wed, 04 August 2010 18:15 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
Yes, thanks for the fix. Everything seems to be working now.

Jeremy
Re: Using SVN from U++ [message #28694 is a reply to message #27652] Sun, 12 September 2010 10:55 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
dolik.rce wrote on Tue, 27 July 2010 13:41

Some time ago I run into similar problem, but I was not able to reproduce it... until now Smile The troubles are caused by the design flaw in theide. The syncing options don't show up when at least one of the nests is not svn working copy.

I enclose the patched files form uppsrc/ide, you can try to recompile theide and test it. If Mirek agrees, I'll commit the changes ASAP.

Best regards,
Honza


This fix is incorrect, reverted.

The problem is that it now lists some folders multiple times.

Mirek
Re: Using SVN from U++ [message #28705 is a reply to message #21749] Mon, 13 September 2010 11:42 Go to previous message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

I see the troubles it caused. I'm sorry for the trouble. Also, no matter how hard I try, I am not able to replicate the troubles originally reported by Jeremy Embarassed

Everything seems to be working even with the patch removed. So, if you run into some troubles, just post again please.

Best regards,
Honza
Previous Topic: Bug in package handling
Next Topic: Can't browse filesystem in TheIDE
Goto Forum:
  


Current Time: Wed Nov 20 21:08:12 CET 2019

Total time taken to generate the page: 0.02098 seconds