Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Problems with making in Ubuntu9.04
Problems with making in Ubuntu9.04 [message #22299] Thu, 02 July 2009 08:05 Go to next message
forestgril is currently offline  forestgril
Messages: 1
Registered: July 2009
Junior Member
Hello,

I don't know how it is with other Ubuntu versions, but I get compilation error in mine:

-------------------------------
CtrlLib/ChGtk.cpp:21:21: error: gtk/gtk.h: No such file or directory
CtrlLib/ChGtk.cpp:22:22: error: gdk/gdkx.h: No such file or directory
CtrlLib/ChGtk.cpp:47: error: expected constructor, destructor, or type conversion before ‘*’ token
CtrlLib/ChGtk.cpp:1259: error: expected `}' at end of input
make[1]: *** [_out/CtrlLib/GCCMK-Gcc-Gui-Linux-Posix-Shared/ChGtk.o] Błąd 1
make[1]: Opuszczenie katalogu `/home/spaceface/Pulpit/upp-x11-src-1314/uppsrc'
cp: nie można wykonać stat na `uppsrc/ide.out': No such file or directory
make: *** [all] Błąd 1
----------------------------------

Could anyone help?

Thanks
Re: Problems with making in Ubuntu9.04 [message #22300 is a reply to message #22299] Thu, 02 July 2009 08:23 Go to previous messageGo to next message
koldo is currently offline  koldo
Messages: 3033
Registered: August 2008
Ultimate Member
Hello forestgril

Which Upp version are using and how have you installed it?

Best regards
Koldo


Best regards
IĂąaki
Re: Problems with making in Ubuntu9.04 [message #22301 is a reply to message #22300] Thu, 02 July 2009 08:55 Go to previous messageGo to next message
andrei_natanael is currently offline  andrei_natanael
Messages: 262
Registered: January 2009
Experienced Member
Hi, I think it doesn't matter which version if he's using U++ compiled from Makefile. The problem is that you don't have installed the development package for gtk and IIRC you have to install all libs needed by U++ manually if you build theIDE from Makefile. Deb package provided for 64bit handle these dependencies, if you want a complete list of U++ dependencies extract *.deb archive and open control file from it, there are listed all dependencies.
Quote:

gcc-4.1 | gcc-4.3, g++-4.1 | g++-4.3, libc6-dev (>= 2.3.6), libstdc++6-4.1-dev (>= 3.4.6) | libstdc++6-4.3-dev , libx11-dev (>= 1.0.0), libxft-dev (>= 2.1.Cool, zlib1g-dev (>= 1.2.3), libpng12-dev (>= 1.2.Cool, libfontconfig1-dev (>= 2.3.2), libxrender-dev (>= 0.9.0), libfreetype6-dev (>= 2.1.10), libexpat1-dev (>= 1.95.Cool, libxau-dev (>= 1.0.0), libxdmcp-dev (>= 1.0.0), libgtk2.0-dev (>= 2.8.17), libglib2.0-dev (>= 2.10.2)

You need just one version of compiler(except g++-4.2 which is known to be buggy).

Andrei
Re: Problems with making in Ubuntu9.04 [message #22308 is a reply to message #22301] Thu, 02 July 2009 16:30 Go to previous message
koldo is currently offline  koldo
Messages: 3033
Registered: August 2008
Ultimate Member
Hello all

To simplify a little bit the job a simple thing would be:

1. To install Upp 32 from and old .deb package in http://www.ultimatepp.org/svnbuilds/

2. Copy over it a new .tar.gz file from http://code.google.com/p/upp-mirror/downloads/list

3. Compile theIde.

Best regards
Koldo


Best regards
IĂąaki
Previous Topic: mingw still supported?
Next Topic: Mingw/GCC 4.4.0 linker warnings
Goto Forum:
  


Current Time: Thu Nov 21 14:48:21 CET 2019

Total time taken to generate the page: 0.02302 seconds