Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Releasing U++ » .deb libnotify-dev warning!
.deb libnotify-dev warning! [message #24568] Sun, 24 January 2010 18:52 Go to next message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
Hi,

as I have accepted TrayIcon patch that requires libnotify, it should be now added to .deb requirements.

I have done so for infrastructure server, at least I hope. Please report any problems with next automated deb64 release.

Mirek
Re: .deb libnotify-dev warning! [message #24570 is a reply to message #24568] Sun, 24 January 2010 19:31 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

Hi Mirek,
Thanks for warning, it probably saves me few hours of investigation why the buildscripts doesn't work all of a sudden Smile

Honza
Re: .deb libnotify-dev warning! [message #24581 is a reply to message #24568] Mon, 25 January 2010 09:11 Go to previous messageGo to next message
tojocky is currently offline  tojocky
Messages: 607
Registered: April 2008
Location: UK
Contributor

Mirek,

Please apply this patch for correct compile in win32!
Problem Description: you had include glib.h and libnotify/notify.h for win 32 too!
Patch text:
Index: uppsrc/CtrlLib/TrayIconX11.cpp
===================================================================
--- uppsrc/CtrlLib/TrayIconX11.cpp	(revision 1945)
+++ uppsrc/CtrlLib/TrayIconX11.cpp	(working copy)
@@ -2,6 +2,8 @@
 
 #define LLOG(x) // LOG(x)
 
+#ifdef PLATFORM_X11
+
 #if !defined(flagNOGTK)
 	#include <glib.h>
 	#include <libnotify/notify.h>
@@ -9,8 +11,6 @@
 
 NAMESPACE_UPP
 
-#ifdef PLATFORM_X11
-
 Atom TraySelection()
 {
 	return XAtom(Format("_NET_SYSTEM_TRAY_S%d", Xscreenno));
@@ -226,6 +226,6 @@
 }
 
 
+END_UPP_NAMESPACE
+
 #endif
-
-END_UPP_NAMESPACE

luzr wrote on Sun, 24 January 2010 19:52

Hi,

as I have accepted TrayIcon patch that requires libnotify, it should be now added to .deb requirements.

I have done so for infrastructure server, at least I hope. Please report any problems with next automated deb64 release.

Mirek

[Updated on: Mon, 25 January 2010 09:16]

Report message to a moderator

Re: .deb libnotify-dev warning! [message #24582 is a reply to message #24581] Mon, 25 January 2010 09:30 Go to previous message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
Ops. Thanks.
Previous Topic: 32 bit .deb releases
Next Topic: Maybe we need to make a deb-repository?
Goto Forum:
  


Current Time: Thu Nov 21 19:43:50 CET 2019

Total time taken to generate the page: 0.00985 seconds