Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » build debs
build debs [message #26645] Tue, 18 May 2010 00:22 Go to next message
sapiency is currently offline  sapiency
Messages: 56
Registered: September 2008
Member
Hi,

it was a few month ago when I build upp at last ...

I found the new scripts, but there was still a little bit of work to do until I got a deb ...

first I converted the files in the folder with
cd uppbox/Scripts
dos2unix *

because my system does not like dos-formated files ...

the next step took me very long, because I didn't noticed that the file "uppsrc/ide/version.h" does not include a version number if you take the sources from svn ...

To solve this I modified the file "uppnighty2deb" and insert
release="`svn info | grep Revision | awk '{print ($2)}'`"

before
echo "building .deb for nighty build $release"


now it works again ...

regards

Reinhard

ps:
system-info: debian testing
Re: build debs [message #26647 is a reply to message #26645] Tue, 18 May 2010 01:01 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

sapiency wrote on Tue, 18 May 2010 00:22

Hi,

it was a few month ago when I build upp at last ...

I found the new scripts, but there was still a little bit of work to do until I got a deb ...

first I converted the files in the folder with
cd uppbox/Scripts
dos2unix *

because my system does not like dos-formated files ...

the next step took me very long, because I didn't noticed that the file "uppsrc/ide/version.h" does not include a version number if you take the sources from svn ...

To solve this I modified the file "uppnighty2deb" and insert
release="`svn info | grep Revision | awk '{print ($2)}'`"

before
echo "building .deb for nighty build $release"


now it works again ...

regards

Reinhard

ps:
system-info: debian testing

Hi Reinhard!
First, those scripts are little bit obsolete... They are not used nor maintained since I wrote the launchpad build scripts (lpbuild). End even before, they were quite out-dated and superseded by uppbox/Scripts/builddeb (based on the original scripts, but heavily rewriten and probably user-friendlier). But I didn't touch that script quite a long time either...

I understand, that it might be difficult/impossible to use Ubuntu packages on Debian, but there is a solution (at least I think it should work Smile )

Launchpad doesn't build only deb packages, but also debian source packages. If you add
deb-src http://ppa.launchpad.net/dolik-rce/upp-nightly/ubuntu lucid main 
to your /etc/apt/sources.list, you can build and install the package using apt-get (or possibly some other standard tool):
apt-get source upp --compile

This will download latest dsc, compile it and create a deb packages (upp,theide and theide-nogtk), which can be then installed as usually. The dsc is general enough so that it should be able to build on Debian without any troubles with libraries (as might be the case with debs). The only weird thing will be "lucid" in a version string, but that should not cause any troubles.

Can you test this way and let me know if I'm correct?

Also, I plan to eventually add support for Debian into lpbuild, but I'm unfortunately busy with other things right now, so it won't be anytime soon.

As for the rest of your post:

Dos-formating should be handled by svn when you check out those files. I'm not sure why it doesn't work on your system.

To get svn version, you can also use svnversion, it should be installed with the subversion package. Your grep&awk solution is of course valid as well Smile

Best regards,
Honza
Re: build debs [message #26740 is a reply to message #26647] Mon, 24 May 2010 21:56 Go to previous messageGo to next message
sapiency is currently offline  sapiency
Messages: 56
Registered: September 2008
Member
Hi Honza,

I'd like to build a deb from the svn-version I picked out. This can be the latest one, but not have to be ...

and I tried only the scripts which where already executable Wink, but after testing builddeb, I can tell you it works fine for me.

regards

Reinhard
Re: build debs [message #26741 is a reply to message #26740] Mon, 24 May 2010 22:29 Go to previous message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

To build custom svn version, just checkout whatever version you want
svn checkout -r 456 http://upp-mirror.googlecode.com/svn/trunk/ /tmp/svn456
and then point the buildeb to this working copy
SRC_PATH="/tmp/svn456"
The rest should work just fine Wink

Honza
Previous Topic: Compiler or LINK options = MSC9 build
Next Topic: Failed compiling theide 2467
Goto Forum:
  


Current Time: Sat Jul 13 03:22:29 CEST 2024

Total time taken to generate the page: 0.02273 seconds