Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » ide compilation on linux - missing libraries? -[MISSING MAKEFILE]
ide compilation on linux - missing libraries? -[MISSING MAKEFILE] [message #2857] Fri, 28 April 2006 11:19 Go to next message
kernow is currently offline  kernow
Messages: 1
Registered: April 2006
Junior Member
I tried compiling upp-604-dev4 from source using gcc-4.1.0 on linux.

compiling seems ok, but the link failed with lots of references to missing FileStream, such as

c++ -o upp-ide -Wl,-s -L/usr/X11R6/lib -L/usr/lib -L/lib -lc -Wl,-O,2 \
build/ide/SelectPkg.o \
build/ide/UppWspc.o \
build/ide/UppDlg.o \
build/ide/Template.o \
build/ide/FindInFiles.o \
build/ide/Console.o \
build/ide/ide.o \
build/ide/idefile.o \
build/ide/QuickTabs.o \
build/ide/Bottom.o \
build/ide/t.o \
build/ide/Assist.o \
build/ide/Virtuals.o \
build/ide/Thisbacks.o \
build/ide/Goto.o \
build/ide/Setup.o \
build/ide/Custom.o \
build/ide/idetool.o \
build/ide/Install.o \
build/ide/idebar.o \
build/ide/idewin.o \
build/ide/Help.o \
build/ide/Util.o \
build/ide/Macro.o \
build/ide/Calc.o \
build/ide/Methods.o \
build/ide/AutoSetup.o \
build/ide/OutputMode.o \
build/ide/Host.o \
build/ide/Build.o \
build/ide/Debug.o \
-Wl,--start-group \
build/ide/Common/Common.a \
build/ide/LayDes/LayDes.a \
build/ide/IconDes/IconDes.a \
build/ide/Builders/Builders.a \
build/ide/Debuggers/Debuggers.a \
build/ide/Browser/Browser.a \
build/ide/Topic/Topic.a \
build/ide/VectorDes/VectorDes.a \
build/CodeEditor/CodeEditor.a \
build/Topic/Topic.a \
build/CtrlLib/CtrlLib.a \
build/Web/Web.a \
build/plugin/bz2/bz2.a \
build/HexView/HexView.a \
build/Esc/Esc.a \
build/Core/Core.a \
build/RichEdit/RichEdit.a \
build/plugin/png/png.a \
build/plugin/gif/gif.a \
build/Image/Image.a \
build/plugin/tif/tif.a \
build/plugin/jpg/jpg.a \
build/Draw/Draw.a \
build/plugin/z/z.a \
build/coff/binobj/binobj.a \
build/coff/coff.a \
build/plugin/ndisasm/ndisasm.a \
build/CppBase/CppBase.a \
build/VectorDes/VectorDes.a \
build/RichText/RichText.a \
build/CtrlCore/CtrlCore.a \
build/PdfDraw/PdfDraw.a \
-lpthread \
-ldl \
-lX11 \
-lXft \
-Wl,--end-group
build/ide/Template.o: In function `FileIn::~FileIn()':
Template.cpp:(.text._ZN6FileInD0Ev[FileIn::~FileIn()]+0xf): undefined reference to `FileStream::~FileStream()'


I did

mkdir -p build &&
make UPPDIR1=uppsrc/ UPPOUT=build/ CINC="-Iuppsrc -I/usr/include/freetype2" \
OutFile=upp-ide LIBPATH="-L/usr/X11R6/lib -L/usr/lib -L/lib -lc"



Am I missing a library?

[Updated on: Tue, 02 May 2006 02:41] by Moderator

Report message to a moderator

Re: upp compilation problems [message #2858 is a reply to message #2857] Fri, 28 April 2006 11:28 Go to previous message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
kernow wrote on Fri, 28 April 2006 05:19

I tried compiling upp-604-dev4 from source using gcc-4.1.0 on linux.

compiling seems ok, but the link failed with lots of references to missing FileStream, such as

c++ -o upp-ide -Wl,-s -L/usr/X11R6/lib -L/usr/lib -L/lib -lc -Wl,-O,2 \
build/ide/SelectPkg.o \
build/ide/UppWspc.o \
build/ide/UppDlg.o \
build/ide/Template.o \
build/ide/FindInFiles.o \
build/ide/Console.o \
build/ide/ide.o \
build/ide/idefile.o \
build/ide/QuickTabs.o \
build/ide/Bottom.o \
build/ide/t.o \
build/ide/Assist.o \
build/ide/Virtuals.o \
build/ide/Thisbacks.o \
build/ide/Goto.o \
build/ide/Setup.o \
build/ide/Custom.o \
build/ide/idetool.o \
build/ide/Install.o \
build/ide/idebar.o \
build/ide/idewin.o \
build/ide/Help.o \
build/ide/Util.o \
build/ide/Macro.o \
build/ide/Calc.o \
build/ide/Methods.o \
build/ide/AutoSetup.o \
build/ide/OutputMode.o \
build/ide/Host.o \
build/ide/Build.o \
build/ide/Debug.o \
-Wl,--start-group \
build/ide/Common/Common.a \
build/ide/LayDes/LayDes.a \
build/ide/IconDes/IconDes.a \
build/ide/Builders/Builders.a \
build/ide/Debuggers/Debuggers.a \
build/ide/Browser/Browser.a \
build/ide/Topic/Topic.a \
build/ide/VectorDes/VectorDes.a \
build/CodeEditor/CodeEditor.a \
build/Topic/Topic.a \
build/CtrlLib/CtrlLib.a \
build/Web/Web.a \
build/plugin/bz2/bz2.a \
build/HexView/HexView.a \
build/Esc/Esc.a \
build/Core/Core.a \
build/RichEdit/RichEdit.a \
build/plugin/png/png.a \
build/plugin/gif/gif.a \
build/Image/Image.a \
build/plugin/tif/tif.a \
build/plugin/jpg/jpg.a \
build/Draw/Draw.a \
build/plugin/z/z.a \
build/coff/binobj/binobj.a \
build/coff/coff.a \
build/plugin/ndisasm/ndisasm.a \
build/CppBase/CppBase.a \
build/VectorDes/VectorDes.a \
build/RichText/RichText.a \
build/CtrlCore/CtrlCore.a \
build/PdfDraw/PdfDraw.a \
-lpthread \
-ldl \
-lX11 \
-lXft \
-Wl,--end-group
build/ide/Template.o: In function `FileIn::~FileIn()':
Template.cpp:(.text._ZN6FileInD0Ev[FileIn::~FileIn()]+0xf): undefined reference to `FileStream::~FileStream()'


I did

mkdir -p build &&
make UPPDIR1=uppsrc/ UPPOUT=build/ CINC="-Iuppsrc -I/usr/include/freetype2" \
OutFile=upp-ide LIBPATH="-L/usr/X11R6/lib -L/usr/lib -L/lib -lc"



Am I missing a library?



No, rather dev4 is missing proper makefile....

In fact, for dev releases, we do not generate makefiles, as we suppose that users will rather compile using existing TheIDE.

In other words, get 602, it will either work as binary out of box (it does on 95% current linuxes), and use it to comple 604dev4.

(If you would like to volunteer for maintaining linux releases including makefiles, just tell Wink

Mirek
Previous Topic: Linux compilation problems with 604.dev2 [3 BUGS]
Next Topic: How to import existing MinGW/C++ projects into TheIDE
Goto Forum:
  


Current Time: Thu Nov 21 06:38:43 CET 2019

Total time taken to generate the page: 0.01718 seconds