Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » g++-4.8
g++-4.8 [message #40890] Mon, 30 September 2013 22:21 Go to next message
piotr5 is currently offline  piotr5
Messages: 107
Registered: November 2005
Experienced Member
anyone tried compiling with newest 4.8?
I tried, and ide-editor has many bugs that way.
sadly I don't have time to upgrade gcc to try again.
even less I have time to debug.
the symptoms are simple:

undo and redo destroy the file, the cursor jumps randomly.
doubleclick on error sometimes moves cursor to end of file.
selecting an area and then navigating elsewhere changes pos.
same when nothing is selected.
copy and paste is difficult for this reason.
eventually ide crashes with memory-error, losing unsaved changes.

my options are
speed: -O3 -ffunction-sections -fdata-sections -fgraphite-identity -floop-interchange -floop-strip-mine -floop-block -ftree-loop-distribution
size: -Os -finline-limit=20 -ffunction-sections -fdata-sections -fgraphite-identity -floop-interchange
linker: -Wl,--gc-sections -Os -fuse-linker-plugin

needless to say, I compiled my gcc-4.8.0 with graphite support. but meanwhile there's a newer version. of course using lto did result in even worse behaviour. when I use the older gcc-4.6.3 I have no such problems, everything works perfectly.

please someone with time at hand, check if theide works on newest g++-4.8 versions.
Re: g++-4.8 [message #40891 is a reply to message #40890] Tue, 01 October 2013 06:39 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

Hi piotr5,

I'm using gcc 4.8.1 and I did use 4.8.0 before for a long time (since it was released) and I never saw such problems... I use only fairly standard flags, -O3 -ffunction-sections -fdata-sections, no graphite etc. Can you try without those fancy switches?

Also, what distribution are you using?

Best regards,
Honza
Re: g++-4.8 [message #40895 is a reply to message #40890] Tue, 01 October 2013 20:49 Go to previous messageGo to next message
piotr5 is currently offline  piotr5
Messages: 107
Registered: November 2005
Experienced Member
you're right,it's graphite.
I removed -fgraphite-identity -floop-interchange and it works.
I still am curious, did anyone get it to work with graphite?

my distro of choice for now is gentoo.
switching on graphite there is just a matter of USE flags...
Re: g++-4.8 [message #41248 is a reply to message #40890] Mon, 18 November 2013 16:04 Go to previous message
mr_ped is currently offline  mr_ped
Messages: 825
Registered: November 2005
Location: Czech Republic - Praha
Experienced Contributor
I have seen undo/redo destroying file content for years in IDE, even with older GCC, though I can't nail it down when it happens.
Previous Topic: Cannot open include file: 'windef.h'
Next Topic: How to compile svn-package with NoGTK?
Goto Forum:
  


Current Time: Thu Jun 13 15:40:51 CEST 2024

Total time taken to generate the page: 0.01953 seconds