Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » How to compile svn-package with NoGTK?
How to compile svn-package with NoGTK? [message #41595] Sat, 04 January 2014 10:24 Go to next message
slashupp is currently offline  slashupp
Messages: 193
Registered: July 2009
Experienced Member
I'm using http://www.ultimatepp.org/downloads/upp-x11-src-6715.tar.gz to build, but it does so using GTK by default.

I do not want GTK, how do I compile this package using the nogtk-flag?
Re: How to compile svn-package with NoGTK? [message #41596 is a reply to message #41595] Sat, 04 January 2014 11:17 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

slashupp wrote on Sat, 04 January 2014 10:24

I'm using http://www.ultimatepp.org/downloads/upp-x11-src-6715.tar.gz to build, but it does so using GTK by default.

I do not want GTK, how do I compile this package using the nogtk-flag?

Hi slashupp,

I'm afraid that is not really possible with the pregenerated makefile Sad

But if you wish, you can grab a copy of the universal makefile and run it like this:
cd upp-x11-src-6715
make -f /path/to/mkfile PKG=ide FLAGS=".NOGTK GUI GCC"

That should do the trick. It also works for most other packages. More details about the usage can be found in the makefile itself.

Best regards,
Honza
Re: How to compile svn-package with NoGTK? [message #41597 is a reply to message #41596] Sat, 04 January 2014 11:58 Go to previous messageGo to next message
slashupp is currently offline  slashupp
Messages: 193
Registered: July 2009
Experienced Member
Thx Honza

Tried it, result:

slashupp:~/upp_tar_6715_nogtk/upp-x11-src-6715$ make -f ../mkfile PKG=ide FLAGS=".NOGTK GUI GCC"
Extracting parser...
0.00user 0.00system 0:00.00elapsed ?%CPU (0avgtext+0avgdata 3680maxresident)k
0inputs+0outputs (0major+290minor)pagefaults 0swaps
Compiling parser...
0.20user 0.01system 0:00.22elapsed 95%CPU (0avgtext+0avgdata 113328maxresident)k
0inputs+2016outputs (0major+14133minor)pagefaults 0swaps
Extracting brc parser...
0.00user 0.00system 0:00.00elapsed ?%CPU (0avgtext+0avgdata 3664maxresident)k
0inputs+0outputs (0major+289minor)pagefaults 0swaps
Extracting colorizer script...
0.00user 0.00system 0:00.00elapsed ?%CPU (0avgtext+0avgdata 3680maxresident)k
0inputs+0outputs (0major+290minor)pagefaults 0swaps
/bin/sh: 5: Syntax error: "then" unexpected (expecting "done")
make: *** [do-build] Error 2

Any advice?
Re: How to compile svn-package with NoGTK? [message #41598 is a reply to message #41597] Sat, 04 January 2014 12:28 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

Can you please run it once more with
make -f /path/to/mkfile PKG=ide FLAGS=".NOGTK GUI GCC" ECHO=1 e=


You can also add "TIME=" to get rid of those ugly timings, which don't work on some shells for some reason I haven't yet found...

Honza
Re: How to compile svn-package with NoGTK? [message #41599 is a reply to message #41598] Sat, 04 January 2014 12:46 Go to previous messageGo to next message
slashupp is currently offline  slashupp
Messages: 193
Registered: July 2009
Experienced Member
Didn't work with the command ending in: e=
but when I added TIME= it seems to do something but failed with:

//snip..
_out/CtrlLib/GCC.GUI.LINUX.NOGTK.POSIX/CtrlLib.a(StatusBar.c pp.o):(.rodata._ZTVN3Upp8InfoCtrlE[_ZTVN3Upp8InfoCtrlE]+0x10 ): undefined reference to `Upp::Ctrl::EventProc(Upp::Ctrl::XWindow&, _XEvent*)'
_out/CtrlLib/GCC.GUI.LINUX.NOGTK.POSIX/CtrlLib.a(StatusBar.c pp.o):(.rodata._ZTVN3Upp8InfoCtrlE[_ZTVN3Upp8InfoCtrlE]+0x18 ): undefined reference to `Upp::Ctrl::HookProc(_XEvent*)'
_out/CtrlLib/GCC.GUI.LINUX.NOGTK.POSIX/CtrlLib.a(TreeCtrl.cp p.o):(.rodata._ZTVN3Upp10OptionTreeE[_ZTVN3Upp10OptionTreeE] +0x10): undefined reference to `Upp::Ctrl::EventProc(Upp::Ctrl::XWindow&, _XEvent*)'
_out/CtrlLib/GCC.GUI.LINUX.NOGTK.POSIX/CtrlLib.a(TreeCtrl.cp p.o):(.rodata._ZTVN3Upp10OptionTreeE[_ZTVN3Upp10OptionTreeE] +0x18): undefined reference to `Upp::Ctrl::HookProc(_XEvent*)'
_out/CtrlLib/GCC.GUI.LINUX.NOGTK.POSIX/CtrlLib.a(TreeCtrl.cp p.o):(.rodata._ZTVN3Upp8TreeCtrlE[_ZTVN3Upp8TreeCtrlE]+0x10) : undefined reference to `Upp::Ctrl::EventProc(Upp::Ctrl::XWindow&, _XEvent*)'
_out/CtrlLib/GCC.GUI.LINUX.NOGTK.POSIX/CtrlLib.a(TreeCtrl.cp p.o):(.rodata._ZTVN3Upp8TreeCtrlE[_ZTVN3Upp8TreeCtrlE]+0x18) : undefined reference to `Upp::Ctrl::HookProc(_XEvent*)'
collect2: error: ld returned 1 exit status
make[1]: *** [_out/bin/ide] Error 1
\e[1mPackage\e[0m \e[1;34mide\e[0m\e[1m finished ...\e[0m
for pkg in ide; do \
if [ "0" = "1" ]; then \
for target in "" "_out/bin/" "_out/bin/$pkg"; do \
[ -f "$target" ] && break; \
done; \
[ -e "$target" ] && { [ "0" = "1" ] || echo "Running $target"; } && $target; \
fi; \
done
~$
//..snip
Re: How to compile svn-package with NoGTK? [message #41600 is a reply to message #41598] Sat, 04 January 2014 12:59 Go to previous messageGo to next message
slashupp is currently offline  slashupp
Messages: 193
Registered: July 2009
Experienced Member
(I would normally use the debian-repos, but ever since this message:
http://www.ultimatepp.org/forum/index.php?t=msg&th=7814& amp;start=0&
those repos does not work)
Re: How to compile svn-package with NoGTK? [message #41601 is a reply to message #41600] Sat, 04 January 2014 14:40 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 636
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello slashupp

For me following command do the trick:
make -f mkfile PKG=ide FLAGS="GUI X11 MT SSE2" ECHO=1 e= TIME=


P.S.
Flag ".NoGTK" dosen't turn off GTK backend! (Use X11 insted of it).

P.S 2
After compiling Ide the new binary version can be found in following dir: _out/bin/ide (Just copy it to your standard upp dir and rename executable to "theide")

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Re: How to compile svn-package with NoGTK? [message #41603 is a reply to message #41601] Sat, 04 January 2014 15:34 Go to previous messageGo to next message
slashupp is currently offline  slashupp
Messages: 193
Registered: July 2009
Experienced Member
thx klugier

well, it compiled and runs .. but only shows an empty package/assembly selector

and there are no upp-directories, only a .upp - how do I set all this up and get theide to find them?

(this feels like it's getting messy - is there a better way in which I can setup a no-gtk theide where it creates what it needs by itself?)


Re: How to compile svn-package with NoGTK? [message #41604 is a reply to message #41603] Sat, 04 January 2014 16:39 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 636
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello slashupp,

Quote:


well, it compiled and runs .. but only shows an empty package/assembly selector



Did you copy "ide" to directory where TheIDE was installed before (or move it to directory where it should be after standard compilation process). If it doesn't help just configure ide one more time.

Quote:


(this feels like it's getting messy - is there a better way in which I can setup a no-gtk theide where it creates what it needs by itself?)



I think, we should think about adding configuration script to POSIX Ultimate++ distribution. BTW standard makefile has got one important limitation it uses only one core. Configure file will enable us getting rid of this limitation.

**********************************
P.S. (Very important!!!)
Make sure that binary file calls "theide" insted of "ide".

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.

[Updated on: Sat, 04 January 2014 17:47]

Report message to a moderator

Re: How to compile svn-package with NoGTK? [message #41609 is a reply to message #41595] Sun, 05 January 2014 12:44 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

First of all, thanks klugier for help, while I was off-line Smile You were only slightly wrong:
klugier

P.S.
Flag ".NoGTK" dosen't turn off GTK backend! (Use X11 insted of it).
This is already fixed, so that NOGTK implies X11 backend Wink

Now, back to the topic Smile It's good to hear that you got it working slashupp, the configuration shouldn't be that hard now. As Klugier noted, it is important to use 'theide' as an executable name, because it then searches for config in ~/.upp/<name>/. If you're trying to install on fresh system (no previous upp installation), you should take a look into doinstall file in the sources, it contains all commands needed for basic installation. You could probably even run it as is, provided you move the compiled theide binary into the same folder. Alternatively, on fresh install theide should present you with the source management wizard on the first run. That should help you to set up the assemblies etc. correctly...

slashupp

(I would normally use the debian-repos, but ever since this message:
http://www.ultimatepp.org/forum/index.php?t=msg&th=7814& amp; amp;start=0&
those repos does not work)
I already tried to figure that issue out few times, but still no success :-/ Meanwhile, you could use packages from OBS. To add the repository to your system, add following to your /etc/apt/sources.list:
deb http://download.opensuse.org/repositories/home:/dolik_rce:/nightly/Debian_7.0 ./
Supported architectures are i586 and x84_64. Debian 6.0 repository exists as well, but GTK backend currently doesn't compile there, so entire package build fails Sad Also note, that the word "nightly" doesn't mean it is updated every night, I just push new version (based on actual nightly sources) from time to time (but still by far more often then the official releases), at least once a month, but usually about once a week or often.

And last bit of information Smile Out of curiosity, I dug out the exact invocation of the makefile that is used when building the debian packages and therefore should be also suitable for you:
make -f mkfile JOBS=1 PKG=ide "NESTS=uppsrc" CC="cc -g" CXX="c++ -g" CFLAGS="-g" CXXFLAGS="-g" LDFLAGS="-Wl,--gc-sections -Wl,-O,2" TIME= COLOR=0 USEMAINCFG=0 "FLAGS=GUI NOGTK GCC" TARGET=`pwd`/theide
It is bit more complex, but not much Smile Also, it keeps debugging symbols (those would be striped out later when packaging it), so it will produce larger binary. Just remove the CFLAGS, CXXFLAGS, CXX and CC switches to prevent that if you want.

Best regards,
Honza
Re: How to compile svn-package with NoGTK? [message #41635 is a reply to message #41609] Mon, 06 January 2014 21:05 Go to previous message
Klugier is currently offline  Klugier
Messages: 636
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello dolik.rce,

For me X11 flag works as expectead. It means that GTK is still use as theme base. Rendering is performed using X11. Personally, I use this flag, because GTK backend is still unstable in some cases.

NOGTK totaly removed GTK. The main theme will be "Standard Theme" (No GTK chameleon).

So I don't think that I was wrong.

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Previous Topic: g++-4.8
Next Topic: freetype problem
Goto Forum:
  


Current Time: Wed Nov 13 13:05:27 CET 2019

Total time taken to generate the page: 0.02004 seconds