Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: CodeEditor, Assist++, Topic++ » [BUG] Or at least strange behavior, in Set active
[BUG] Or at least strange behavior, in Set active [message #44935] Sat, 25 July 2015 19:12
rxantos is currently offline  rxantos
Messages: 71
Registered: October 2011
Member
When one switches the group by right clicking the IDE TabBar, instead of switching the file to the selected group it remains on the same group that the original file was. Which pretty much makes useless the "Set active" item.

What happens is that TabBar::DoGrouping is called twice. One for the group you selected. Another to switch to the group of the file you are in. Thus the selected group remains the same.

Ideally it should.
- Save the name of the selected file of the group you are in.
- If there is a selected file in the group you want to go, switch to that file.
- If not, then switch to the first file in the group you want to go.

But it shouldn't (as it does now).
- Switch to the group you want to go.
- And then switch back to the group of the file you are in. As this makes selecting the group USELESS.
Previous Topic: [BUG?] Ctrl+LBC
Next Topic: how to create .tppi and .i files (and a working .tpp in a RichTextView)
Goto Forum:
  


Current Time: Fri Nov 15 08:47:40 CET 2019

Total time taken to generate the page: 0.01595 seconds