Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » IDE compilation error
IDE compilation error [message #45922] Tue, 26 January 2016 13:29 Go to next message
pvictor is currently offline  pvictor
Messages: 26
Registered: December 2015
Location: Russia
Promising Member
Starting from upp-x11-src-9424.tar.gz, I get the following error when compiling TheIDE:
Core/Mt.cpp: In function 'void Upp::ReadMemoryBarrier()':                                                   
Core/Mt.cpp:372:6: error: redefinition of 'void Upp::ReadMemoryBarrier()'                                   
 void ReadMemoryBarrier()                                                                                   
      ^                                                                                                     
In file included from Core/Core.h:251:0,                                                                    
                 from Core/Mt.cpp:1:                                                                        
Core/Mt.h:152:13: error: 'void Upp::ReadMemoryBarrier()' previously defined here                            
 inline void ReadMemoryBarrier()                                                                            
             ^                                                                                              
Core/Mt.cpp: In function 'void Upp::WriteMemoryBarrier()':                                                  
Core/Mt.cpp:394:6: error: redefinition of 'void Upp::WriteMemoryBarrier()'                                  
 void WriteMemoryBarrier() {                                                                                
      ^                                                                                                     
In file included from Core/Core.h:251:0,                                                                    
                 from Core/Mt.cpp:1:                                                                        
Core/Mt.h:157:13: error: 'void Upp::WriteMemoryBarrier()' previously defined here                           
 inline void WriteMemoryBarrier()                                                                           
             ^                                                                                              


upp-x11-src-9418.tar.gz compiles OK.

Linux Mint 17.3 Cinnamon 32-bit

Victor
Re: IDE compilation error [message #45940 is a reply to message #45922] Fri, 29 January 2016 07:13 Go to previous messageGo to next message
kasome is currently offline  kasome
Messages: 78
Registered: July 2008
Location: Taiwan
Member
Hi

I meet the same problem when i try to compile theide of upp-x11-src-9436 on Ubuntu 12.04 32bit


The following is the solution I can get, but it may not be the best

open the file in "upp-x11-src-9436/uppsrc/Makefile.in", then try to find

Macro = -DflagGUI -DflagMT -DflagGCC -DflagSHARED -DflagLINUX -DflagPOSIX

and modify to

Macro = -DflagGUI -DflagMT -DflagGCC -DflagSHARED -DflagLINUX -DflagPOSIX -DflagSSE2


save the file, and try to compile again.

[Updated on: Fri, 29 January 2016 07:16]

Report message to a moderator

Re: IDE compilation error [message #45953 is a reply to message #45940] Sun, 31 January 2016 10:37 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12106
Registered: November 2005
Ultimate Member
I believe it is now fixed.

Mirek
Re: IDE compilation error [message #45976 is a reply to message #45922] Fri, 05 February 2016 07:57 Go to previous messageGo to next message
pvictor is currently offline  pvictor
Messages: 26
Registered: December 2015
Location: Russia
Promising Member
This error still exists in upp-x11-src-9448.tar.gz

TheIDE doesn't compile unless I manually add -DflagSSE2 to MACRO in uppsrc/Makefile.in

Core/Mt.cpp:
#ifdef CPU_X86
#ifndef CPU_SSE2
 . . .
void ReadMemoryBarrier() {
 . . .
}

Core/Mt.h:
#ifdef CPU_SSE2
inline void ReadMemoryBarrier() {
 . . .
}
 . . .
#elif defined(COMPILER_GCC)
#ifndef PLATFORM_WIN32
inline void ReadMemoryBarrier() {
 . . .
}

If CPU_X86 and COMPILER_GCC are defined but CPU_SSE2 and PLATFORM_WIN32 are undefined
ReadMemoryBarrier() (and WriteMemoryBarrier()) are duplicated.

Victor
Re: IDE compilation error [message #46117 is a reply to message #45976] Wed, 09 March 2016 12:51 Go to previous messageGo to next message
deep is currently offline  deep
Messages: 197
Registered: July 2011
Location: Bangalore
Experienced Member
I am getting the same error from latest code

Ubuntu 14.04-4

Running make ,

Source from

https://launchpad.net/~dolik-rce/+archive/ubuntu/upp-nightly /+files/upp_9584.orig.tar.gz

I checked with -DflagSSE2 adding it in makefile.in MACRO. but get same error.
make clean
make

c++ -c -x c++ -O3 -ffunction-sections -fdata-sections  -I./ -I/usr/include/gtk-2.0 -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/harfbuzz   -I/usr/include/freetype2 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/X11R6/include -I/usr/X11R6/include/freetype2 -I/usr/X11R6/include/gtk-2.0 -I/usr/X11R6/include/glib-2.0 -I/usr/X11R6/lib/glib-2.0/include -I/usr/X11R6/lib/gtk-2.0/include -I/usr/X11R6/include/cairo -I/usr/X11R6/include/pango-1.0 -I/usr/X11R6/include/atk-1.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gtkglext-1.0 -I/usr/lib/gtkglext-1.0/include -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -DflagGUI -DflagMT -DflagGCC -DflagSHARED -DflagLINUX -DflagPOSIX  Core/Mt.cpp -o _out/Core//home/upp/Scripts/GCCMK.bm-Gcc-Gui-Linux-Mt-Posix-Shared/Mt.o
Core/Mt.cpp: In function 'void Upp::ReadMemoryBarrier()':
Core/Mt.cpp:372:6: error: redefinition of 'void Upp::ReadMemoryBarrier()'
 void ReadMemoryBarrier()
      ^
In file included from Core/Core.h:251:0,
                 from Core/Mt.cpp:1:
Core/Mt.h:153:13: error: 'void Upp::ReadMemoryBarrier()' previously defined here
 inline void ReadMemoryBarrier()
             ^
Core/Mt.cpp: In function 'void Upp::WriteMemoryBarrier()':
Core/Mt.cpp:394:6: error: redefinition of 'void Upp::WriteMemoryBarrier()'
 void WriteMemoryBarrier() {
      ^
In file included from Core/Core.h:251:0,
                 from Core/Mt.cpp:1:
Core/Mt.h:158:13: error: 'void Upp::WriteMemoryBarrier()' previously defined here
 inline void WriteMemoryBarrier()
             ^
make: *** [_out/Core//home/upp/Scripts/GCCMK.bm-Gcc-Gui-Linux-Mt-Posix-Shared/Mt.o] Error 1



Warm Regards

Deepak

[Updated on: Wed, 09 March 2016 13:14]

Report message to a moderator

Re: IDE compilation error [message #46118 is a reply to message #46117] Thu, 10 March 2016 05:38 Go to previous message
deep is currently offline  deep
Messages: 197
Registered: July 2011
Location: Bangalore
Experienced Member
I installed UPP using ppa and apt-get

Version 9584

Project with MT give following compile error

upp/uppsrc/Core/Mt.cpp: In function 'void Upp::ReadMemoryBarrier()':
upp/uppsrc/Core/Mt.cpp:372:6: error: redefinition of 'void Upp::ReadMemoryBarrier()'
void ReadMemoryBarrier()
^
In file included from upp/uppsrc/Core/Core.h:251:0,
from upp/uppsrc/Core/Mt.cpp:1:
upp/uppsrc/Core/Mt.h:153:13: error: 'void Upp::ReadMemoryBarrier()' previously defined here
inline void ReadMemoryBarrier()
^
upp/uppsrc/Core/Mt.cpp: In function 'void Upp::WriteMemoryBarrier()':
upp/uppsrc/Core/Mt.cpp:394:6: error: redefinition of 'void Upp::WriteMemoryBarrier()'
void WriteMemoryBarrier() {
^
In file included from upp/uppsrc/Core/Core.h:251:0,
from upp/uppsrc/Core/Mt.cpp:1:
upp/uppsrc/Core/Mt.h:158:13: error: 'void Upp::WriteMemoryBarrier()' previously defined here
inline void WriteMemoryBarrier()
^
Core: 1 file(s) built in (0:02.41), 2412 msecs / file, duration = 2826 msecs, parallelization 0%

There were errors. (0:05.99)

I am getting following error and IDE crash.
Fatal error
Assertion failed in /build/upp-Om2NWW/upp-9584/uppsrc/CtrlCore/CtrlTimer.cpp, line 44
abs(delay_ms) < 0x40000000

Stack trace:
() [0x83beff2]
() [0x83bf41c]
() [0x829cc9c]
() [0x829d258]
() [0x8479998]
() [0x845cc4a]
() [0x83c8d48]
() [0x80baad5]
() [0x829d0b5]
() [0x82b07f5]
() [0x82b08d4]
() [0x82b09ed]
() [0x82a1974]
() [0x8456bd4]
() [0x84552ea]
(__libc_start_main
() [0x8052270]



This error happened during upp install also.

Compiled programs are running for long time without crash.

I kept running "Clock" Prog for long time


Warm Regards

Deepak

[Updated on: Thu, 10 March 2016 06:38]

Report message to a moderator

Previous Topic: Slow processing of compilation/linking messages
Next Topic: Compilation error with GCC
Goto Forum:
  


Current Time: Sat Nov 23 00:00:00 CET 2019

Total time taken to generate the page: 0.01162 seconds