Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Releasing U++ » Theide problem on lubuntu 16.04 dolik ppa
Theide problem on lubuntu 16.04 dolik ppa [message #46677] Sat, 02 July 2016 14:07 Go to next message
forlano is currently offline  forlano
Messages: 1194
Registered: March 2006
Location: Italy
Senior Contributor
Hello,

on a fresh 64 bit lubuntu (pendrive) 16.04 installation I have installed the nightly build as explained here
https://launchpad.net/~dolik-rce/+archive/ubuntu/upp-nightly
I have done it several time before with NO errors.

This time I got the following message after the Upp logo

index.php?t=getfile&id=5042&private=0

and then the crash of theide.

Does anybody know what the problem is?

Luigi

  • Attachment: img.png
    (Size: 9.30KB, Downloaded 536 times)

[Updated on: Sat, 02 July 2016 14:08]

Report message to a moderator

Re: Theide problem on lubuntu 16.04 dolik ppa [message #46678 is a reply to message #46677] Sat, 02 July 2016 17:15 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1194
Registered: March 2006
Location: Italy
Senior Contributor
In the meanwhile I have downloaded the linux source code and compiled the theide.
Everything works as expected.

Thanks,
Luigi
Re: Theide problem on lubuntu 16.04 dolik ppa [message #46685 is a reply to message #46677] Fri, 08 July 2016 14:05 Go to previous messageGo to next message
Tom1
Messages: 1217
Registered: March 2007
Senior Contributor
Hi,

I just tried a similar installation from dolik ppa on LinuxMint 18 Cinnamon with similar results. Actually it just freezes at the splash screen and the theide.log shows:

* /usr/bin/theide 08.07.2016 14:56:40, user: tom

****************** ASSERT FAILED: Assertion failed in /build/upp-pBBGQT/upp-9999/uppsrc/Core/Stream.h, line 190
style & STRM_WRITE

Stack trace:
() [0x802809]
() [0x802c45]
() [0x7f927b]
() [0x7f8692]
() [0x7f89ed]
() [0x9c80b1]
() [0x9c5ead]
() [0x9c2bba]
() [0x9c73f8]
() [0x9cd14c]
() [0x47ccfb]
() [0x47b966]
() [0x71fdf7]
() [0x71fea5]
() [0x9c6383]
() [0x9c2698]
() [0x9c666c]
() [0x978105]
() [0x8f7b29]
() [0x8f6346]
(__libc_start_main
() [0x40c2e9]


LastErrorMessage: File exists

The latest build seems to be 9999 -- currently 5 days old, while the SVN is at 10019.

Best regards,

Tom
Re: Theide problem on lubuntu 16.04 dolik ppa [message #46688 is a reply to message #46677] Tue, 12 July 2016 08:36 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

Hi guys,

Sorry for late reply, I've been on vacation Cool

The error seems to indicate writing to Stream in reading mode. However, I see no reasonable way how this could happen in the deb while it works when built from source.

Does it still happen with current build (10031)? There have been some changes and fixes to the core in revisions 10006-10012 that might have fixed this.

Best regards,
Honza
Re: Theide problem on lubuntu 16.04 dolik ppa [message #46689 is a reply to message #46688] Tue, 12 July 2016 09:19 Go to previous messageGo to next message
Tom1
Messages: 1217
Registered: March 2007
Senior Contributor
Hi Honza,

Hope you enjoyed your vacation!

As it turned out, even 9999 from PPA started OK after I had built 10019 from sources and used it. Then I removed ~/.upp/theide directory altogether and tried to restart: I was back to the original crash situation.

Now I just installed 10031 from PPA and removed ~/.upp/theide directory again and tried to start over -- still crashing. Then I restored my ~/.upp/theide from a backup and 10031 works with that too.

So, my conclusion is that when doing 'make install' from sources does something useful that does not get done when installing from PPA.

-- Please note: I'm not in a panic in any way. This only happens with fresh installs. Anyway, it would be nice to have this working, since many new comers might be turned away by installation problems.

Additionally, it would be nice to have the SVN source option pointing to a working SVN mirror instead of Google code with old sources.

Thanks and best regards,

Tom
Re: Theide problem on lubuntu 16.04 dolik ppa [message #46690 is a reply to message #46689] Tue, 12 July 2016 14:19 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

Hi Tom,

Tom1 wrote on Tue, 12 July 2016 09:19
As it turned out, even 9999 from PPA started OK after I had built 10019 from sources and used it. Then I removed ~/.upp/theide directory altogether and tried to restart: I was back to the original crash situation.

Now I just installed 10031 from PPA and removed ~/.upp/theide directory again and tried to start over -- still crashing. Then I restored my ~/.upp/theide from a backup and 10031 works with that too.

So, my conclusion is that when doing 'make install' from sources does something useful that does not get done when installing from PPA.

This is a great hint. I think I've already seen this before, but can't remember what exactly was the problem. Anyway, it should be easy to debug.

Tom1 wrote on Tue, 12 July 2016 09:19
Additionally, it would be nice to have the SVN source option pointing to a working SVN mirror instead of Google code with old sources.
Good idea, but unfortunately, the github mirror doesn't have any information about U++ version. The version is taken directly from the master repository revision, but github revisions are different (even when accessed via its subversion API). The only think I can do is to point it to the main repository. Hopefully, it will not generate too much traffic...

Honza
Re: Theide problem on lubuntu 16.04 dolik ppa [message #46926 is a reply to message #46677] Sat, 17 September 2016 15:04 Go to previous message
sergeynikitin is currently offline  sergeynikitin
Messages: 748
Registered: January 2008
Location: Moscow, Russia
Contributor

I have same situation on Ubuntu LTS 16.04.01

I replace theide by theide from installation from 2013 year.

Download from there https://yadi.sk/d/1XP_kXlgvHuCV


SergeyNikitin<U++>( linux, wine )
{
    under( Ubuntu || Debian || Raspbian );
}
Previous Topic: Not compile example reference/SQL_MySql in ROSA Linux R6
Next Topic: Latest TheIDE builds fail to execute under FreeBSD
Goto Forum:
  


Current Time: Sat Jun 22 22:35:25 CEST 2024

Total time taken to generate the page: 0.01440 seconds