Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » LineEdit, EditFields, DocEdit » line edit problem in designer
line edit problem in designer [message #3120] Sun, 07 May 2006 22:34 Go to next message
forlano is currently offline  forlano
Messages: 1127
Registered: March 2006
Location: Italy
Senior Contributor
With the designer some times I experience problems that provocate the crash of the program. Then I've observed that removing some child from the graphic layout and inserting it directly in the class with Add(ctrl), and setting all its properties, the application works. The last case appeared with line edit just now. Please consider the following layout:
LAYOUT(VegaTab4Layout, 712, 496)
	ITEM(LabelBox, dv___0, SetLabel(t_("View")).LeftPosZ(32, 644).TopPosZ(376, 80))
	ITEM(Button, dv___1, LeftPosZ(484, 68).TopPosZ(424, 19))
	ITEM(Button, dv___2, LeftPosZ(48, 68).TopPosZ(424, 19))
	ITEM(Button, dv___3, LeftPosZ(156, 68).TopPosZ(424, 19))
	ITEM(Button, dv___4, LeftPosZ(272, 68).TopPosZ(424, 19))
	ITEM(Button, dv___5, LeftPosZ(380, 68).TopPosZ(424, 19))
	ITEM(Button, dv___6, LeftPosZ(588, 68).TopPosZ(424, 19))
	ITEM(Button, dv___7, LeftPosZ(484, 68).TopPosZ(396, 19))
	ITEM(Button, dv___8, LeftPosZ(48, 68).TopPosZ(396, 19))
	ITEM(Button, dv___9, LeftPosZ(156, 68).TopPosZ(396, 19))
	ITEM(Button, dv___10, LeftPosZ(272, 68).TopPosZ(396, 19))
	ITEM(Button, dv___11, LeftPosZ(380, 68).TopPosZ(396, 19))
	ITEM(Button, dv___12, LeftPosZ(588, 68).TopPosZ(396, 19))
	ITEM(LineEdit, lineedit, LeftPosZ(32, 644).TopPosZ(20, 348))
END_LAYOUT

with constructor:
VegaTab4::VegaTab4()
{
	CtrlLayout(*this);
	SizePos();
}

provocate the immediate crash of the application. To resolve the problem I need (all other being the same) to delete the line
ITEM(LineEdit, lineedit, LeftPosZ(32, 644).TopPosZ(20, 348))

and use the following constructor
[/code]
and the following constructor
VegaTab4::VegaTab4()
{
	CtrlLayout(*this);
	SizePos();
	Add(lineedit); // code of the previous deleted row
	lineedit.LeftPosZ(32, 644).TopPosZ(20, 348);
}

where I've declared "LineEdit lineedit;" in the class declaration.
Is it normal?

Luigi
Re: line edit problem in designer [message #3121 is a reply to message #3120] Sun, 07 May 2006 22:47 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13442
Registered: November 2005
Ultimate Member
forlano wrote on Sun, 07 May 2006 16:34

Is it normal?



No, but I see no reason. Could you get testing package posted?

Mirek
Re: line edit problem in designer [message #3122 is a reply to message #3121] Sun, 07 May 2006 23:15 Go to previous message
forlano is currently offline  forlano
Messages: 1127
Registered: March 2006
Location: Italy
Senior Contributor
luzr wrote on Sun, 07 May 2006 22:47

forlano wrote on Sun, 07 May 2006 16:34

Is it normal?



No, but I see no reason. Could you get testing package posted?

Mirek


I can of course...
Just now I removed my modifications to reproduce the anomalous behaviour before to post the package... and it decided to work as it should do! Surprised
Maybe it was afraid of you? Very Happy
I can assure that before to signal it I tried many times. Well, in future I'll freeze the package with the problem and start to work with another one.
So I think now make no sense to post it but if you think can be useful just tell me.

Luigi
Previous Topic: Which widget can show text with fixed font?
Next Topic: How to let appear by default the bar in the LineEdit?
Goto Forum:
  


Current Time: Fri Oct 22 20:37:52 CEST 2021

Total time taken to generate the page: 0.01059 seconds