Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » U++ SQL » postgresql mingw ( (): lld-link: error: C:\Ultimate++\upp\bin/pgsql/x86/bin\libpq.dll: bad file type. Did you specify a DLL instead of an import library?)
postgresql mingw [message #51763] Sun, 19 May 2019 07:05 Go to previous message
mtdew3q is currently offline  mtdew3q
Messages: 181
Registered: July 2010
Location: Upstate, NY (near Canada)
Experienced Member

Hi all-

I am fooling around tonight on my 3 day vacation.

I built PostgreSQL with mingw. I built is so it would generate .a and .dll files too.

However, to simplify things I left the path, lib, include all configured like:
C:\Ultimate++\upp\bin/pgsql/x86/bin for instance.

Basically, I said to myself, what is the way that Ultimate++ is right out of the box.
Then I ran the PostgreSQL tutorial code, and I get the error listed in the topic description.
So my question is, why when I didn't change any of the configuration settings to point anywhere else can I not get it to link?
I disabled my paths in environment variables for my mingw that exist outside of the boxed environment for U++.

I have a PostgreSQL server running but can't get it to link anyway. I've been in PostgreSQL and created the schema for the
tutorial test db. I found that when I run conemu from mintty I can use it to run psql.

I tried on static only and shared too. Nothing seems to work.

One final curiosity is that there is a libpq.lib file. I didn't think mingw liked that.

Well, out of the box it doesn't see to run. Not sure why. I am able to run dialogs in the examples, so I know it is
a linker with PostgreSQL problem and not anything to do with the dialogs.

I am running version 13068.

Thanks for any comment.

I am off to get refreshments. Be back to check in on things in a bit.
thnx. Roboloki



 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Sql Lite schema with DATE type
Next Topic: Escape string in MySQL
Goto Forum:
  


Current Time: Sun Jun 23 03:59:54 CEST 2024

Total time taken to generate the page: 0.02190 seconds