Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Compiling, Linking, Debugging of your packages » I keep getting the same "cannot open exe for writing" error...
Re: I keep getting the same "cannot open exe for writing" error... [message #50600 is a reply to message #50484] Sun, 25 November 2018 17:40 Go to previous messageGo to previous message
peterh is currently offline  peterh
Messages: 46
Registered: November 2018
Location: Germany
Member
For me it happens after previous debugging.
(I am on Windows10 64 Bit)
It happens for me when I am using MSVC17 or MSVC17 64 Bit in TheIDE and only after debugging.

In the Windows Taskmanager it can be seen, that the previously debugged process is still attached to TheIDE.
If I choose "Debug" in the Windows Taskmanager then Windows tries to attach the VSstudio debugger.

Attaching VSStudio debugger fails.

There is an error message, which says "There is another debugger attached to this process, which is not configured to handle this kind of exception".

It seems to me, it happens, when the debugee was stopped and had some kind of exception during shutdown and this probably prevented the debugger from detaching.

These are just my observations. (And educated guesses) Hope this is useful.
I have no experience with windows programming, but have used debuggers on DOS and Linux some decades ago.

[Updated on: Sun, 25 November 2018 20:24]

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: error: expected unqualified-id before '=' token
Next Topic: clang or MinGW
Goto Forum:
  


Current Time: Sat Sep 26 01:20:32 CEST 2020

Total time taken to generate the page: 0.01067 seconds