Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Compiling, Linking, Debugging of your packages » I keep getting the same "cannot open exe for writing" error...
Re: I keep getting the same "cannot open exe for writing" error... [message #50613 is a reply to message #50610] Mon, 26 November 2018 12:45 Go to previous messageGo to previous message
peterh is currently offline  peterh
Messages: 46
Registered: November 2018
Location: Germany
Member
Yes, when I see the problem then I try to solve it, or at least look for a way to reproduce it.

I see this problem frequently, because I use the debugger frequently.
Not that I write software, but I work through the examples and if I dont understand something, then I use the debugger to see how stuff works.

I could try the tools from sysinternals to investigate this problem furter, when it happens.

My observation is, sometimes it doesnt happen and sometimes it happens frequently, with the debugee being substancially unchanged.

It is not reproducible, this could be a hint for uninitialized variables, dangling pointer or race condition.

If the problem is in the microsoft dll then only a quick'n dirty workaround would be possible:

Before the build starts, delete the target *.exe file.
Possibly the Windows API has a way to get the filehandle and close and delete the file? (I dont know this; this is just an unproven idea)
If this is not possible rename it and delete it at next start.
Possibly move the exe to temp then windows would delete it.

[Updated on: Mon, 26 November 2018 13:30]

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: error: expected unqualified-id before '=' token
Next Topic: clang or MinGW
Goto Forum:
  


Current Time: Sun Jul 05 02:29:12 CEST 2020

Total time taken to generate the page: 0.01287 seconds