Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Extra libraries, Code snippets, applications etc. » OS Problems etc., Win32, POSIX, MacOS, FreeBSD, X11 etc » [BUG - solved?] HttpRequest fails under FreeBSD
[BUG - solved?] HttpRequest fails under FreeBSD [message #38711] Tue, 08 January 2013 23:36 Go to previous message
Mindtraveller is currently offline  Mindtraveller
Messages: 917
Registered: August 2007
Location: Russia, Moscow rgn.
Experienced Contributor

This sample (for latest SVN) code fails under FreeBSD
#include <Core/Core.h>

using namespace Upp;

CONSOLE_APP_MAIN
{
	HttpRequest::Trace(true);
	HttpRequest http("http://google.com"); //fails with almost any sites even w/o redirect
	String s = http.Execute();
	SaveFile("1", s);
}


It logs error:
Quote:

HTTP START
Starting status 2 'Resolving host name', url: google.com
HTTP StartConnect
HTTP AfterConnect
Starting status 6 'Sending request', url: google.com
HTTP REQUEST google.com:0
HTTP request:
GET / HTTP/1.1
URL: http://google.com/
Host: google.com
Connection: close
Accept: */*
Accept-Encoding: gzip
User-Agent: U++ HTTP request


HTTP Execute: Sending request
HTTP retry on error socket(5) / send: Socket is not connected
Starting status 1 'Start', url: google.com
HTTP Execute: Start
HTTP START
Starting status 2 'Resolving host name', url: google.com
HTTP StartConnect
HTTP AfterConnect
Starting status 6 'Sending request', url: google.com
HTTP REQUEST google.com:0
HTTP request:
GET / HTTP/1.1
URL: http://google.com/
Host: google.com
Connection: close
Accept: */*
Accept-Encoding: gzip
User-Agent: U++ HTTP request


HTTP Execute: Sending request
HTTP retry on error socket(5) / send: Socket is not connected
Starting status 1 'Start', url: google.com
HTTP Execute: Start
HTTP START
Starting status 2 'Resolving host name', url: google.com
HTTP StartConnect
HTTP AfterConnect
Starting status 6 'Sending request', url: google.com
HTTP REQUEST google.com:0
HTTP request:
GET / HTTP/1.1
URL: http://google.com/
Host: google.com
Connection: close
Accept: */*
Accept-Encoding: gzip
User-Agent: U++ HTTP request


HTTP Execute: Sending request
HTTP retry on error socket(5) / send: Socket is not connected
Starting status 1 'Start', url: google.com
HTTP Execute: Start
HTTP START
Starting status 2 'Resolving host name', url: google.com
HTTP StartConnect
HTTP AfterConnect
Starting status 6 'Sending request', url: google.com
HTTP REQUEST google.com:0
HTTP request:
GET / HTTP/1.1
URL: http://google.com/
Host: google.com
Connection: close
Accept: */*
Accept-Encoding: gzip
User-Agent: U++ HTTP request


HTTP Execute: Sending request



Very strange bug.
Proceeding with investigation...

P.S. Tested on defferent systems with different FreeBSD versions with the same result.

[Updated on: Wed, 23 January 2013 19:47]

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Windows 8
Next Topic: U++ for Android?
Goto Forum:
  


Current Time: Wed Dec 08 17:23:27 CET 2021

Total time taken to generate the page: 0.00894 seconds