Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Extra libraries, Code snippets, applications etc. » OS Problems etc., Win32, POSIX, MacOS, FreeBSD, X11 etc » [BUG - solved?] HttpRequest fails under FreeBSD
Re: [BUG] HttpRequest fails under FreeBSD [message #38733 is a reply to message #38731] Thu, 10 January 2013 20:33 Go to previous messageGo to previous message
Mindtraveller is currently offline  Mindtraveller
Messages: 917
Registered: August 2007
Location: Russia, Moscow rgn.
Experienced Contributor

OK, finally managed to find a possible cause of this misfunction. In simple words, under FreeBSD, connecting socket didn't finish at the moment when we start sending data through it. Which resulted in failure with error code "Socket not connected".

So here is my solution which seems to work but may be not that good.
(Core/Socket.spp)
bool TcpSocket::RawConnect(addrinfo *arp)
...
//@445 +++
					if (GetErrorCode() == SOCKERR(EINPROGRESS))
						WaitWrite();
//     +++


If you know better solution how to detect the need and wait socket connection, please propose it.

[Updated on: Fri, 11 January 2013 13:05]

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Windows 8
Next Topic: U++ for Android?
Goto Forum:
  


Current Time: Tue Jan 18 08:56:17 CET 2022

Total time taken to generate the page: 0.03757 seconds