Bug #1098

cpp: ide high memory usage with infinity loop

Added by Zbigniew Rebacz over 5 years ago. Updated about 5 years ago.

Status:RejectedStart date:06/01/2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:IDESpent time:-
Target version:-

Description

This is what i do:
- I select android_builder/ide package
- Then select Examples/Clock
- Ide started scanning and hangs with huge memory consumption - 3,3 GB - My machines needs to use Swap :(

I think this is some kind of inifnity loop with high memory consumption.

I attached photo with memory consumption.

HighMemoryUsage.jpg (821 KB) Zbigniew Rebacz, 06/01/2015 10:15 PM

History

#1 Updated by Miroslav Fidler over 5 years ago

  • Assignee changed from Miroslav Fidler to Zbigniew Rebacz

Unable to reproduce.

Is the problem bound with "File/Set main package.." ? I mean, if choose Examples/Clock after starting a new ide, does it fail?

#2 Updated by Zbigniew Rebacz over 5 years ago

  • Assignee deleted (Zbigniew Rebacz)

I think the bug is still there, but it is harder to catch it due to limiting scanning time.

#3 Updated by Miroslav Fidler about 5 years ago

  • Status changed from New to Rejected

Seems to be duplicate of #1155.

Also available in: Atom PDF