Bug #142

Why is uppweb compilation of web.cpp in linux taking so long?

Added by Miroslav Fidler almost 8 years ago. Updated over 6 years ago.

Status:RejectedStart date:10/24/2011
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-Spent time:-
Target version:-

Description

and wastes so much memory?

uppbox.diff Magnifier - The diff file to apply for uppbox directory (1.05 KB) Sender Ghost, 10/24/2011 10:30 AM

uppweb_fix.diff Magnifier - The diff file to apply for www.cpp (494 Bytes) Sender Ghost, 10/24/2011 12:10 PM

uppbox2.diff Magnifier - The diff file to apply for uppbox directory (second version) (1.36 KB) Sender Ghost, 10/24/2011 02:23 PM

uppbox_full.diff Magnifier - The diff file to apply for uppbox directory (with all changes) (3.96 KB) Sender Ghost, 10/26/2011 09:24 PM

History

#1 Updated by Sender Ghost almost 8 years ago

Circular dependencies?
I created a patch to clean uppweb package a little.

#2 Updated by Sender Ghost almost 8 years ago

  • File uppbox2.diff added

Clean up a little more.

#3 Updated by Sender Ghost almost 8 years ago

And some fix for uppweb/www.cpp file.

#4 Updated by Sender Ghost almost 8 years ago

Ok, found. This is because of following fragment of code:

#define TOPICFILE <uppweb/www.tpp/all.i>
#include <Core/topic_group.h>

#define TOPICFILE <ide/app.tpp/all.i>
#include <Core/topic_group.h>

The preprocessor.

#5 Updated by Sender Ghost almost 8 years ago

  • File deleted (uppbox2.diff)

#6 Updated by Sender Ghost almost 8 years ago

Fixed second version of the clean-up patch (which not very related for this issue).

#7 Updated by Miroslav Fidler almost 8 years ago

Well, looks like it would be smart to rewrite the code not to include topics, just load them during the run...

#8 Updated by Sender Ghost almost 8 years ago

If I comment out these defines, I get almost the same generated pages (except update time stamp for index.html file and www$uppweb$examples$<language>.html files).
I recommend to switch ide package to ide/Browser for uppweb uses, then it will be just 21 packages to build, instead of 39. And use separately opened TheIDE to edit ide/app.tpp topics instead.

#9 Updated by Sender Ghost almost 8 years ago

  • File uppbox_full.diff added
  • Status changed from In Progress to Patch ready

Therefore, there is full version of the patch with all changes.

#10 Updated by Sender Ghost almost 8 years ago

  • File deleted (uppbox_full.diff)

#11 Updated by Sender Ghost almost 8 years ago

  • File uppbox_full.diff added

Just changed description of the attached file.

#12 Updated by Sender Ghost almost 8 years ago

  • File deleted (uppbox_full.diff)

#13 Updated by Sender Ghost almost 8 years ago

Fixed patch a bit.

#14 Updated by Miroslav Fidler almost 8 years ago

  • Status changed from Patch ready to New
  • Priority changed from High to Normal

(switching to 'new'/'Normal' as provided patch does not solve the original problem and the issue is not pressing....)

#15 Updated by Miroslav Fidler over 6 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF