Bug #2142

Header file doesn't display documentation rectangle (IDE, CodeEditor)

Added by Zbigniew Rebacz almost 2 years ago. Updated almost 2 years ago.

Status:RejectedStart date:02/14/2021
Priority:UrgentDue date:
Assignee:Miroslav Fidler% Done:

0%

Category:IDESpent time:-
Target version:Release 2021.1

Description

Documentation rectangles are not display in the header files. It makes analyzing header file much more difficult. It is regression to the previous versions, however I can not find the version which brings regression. It is reproducible on Windows and Linux.

It should be fixed as fast as possible. We need to make sure it will be part of 2021.1 release. I rated it as urgent.

NoDocumentationInsideTheIDE.png (191 KB) Zbigniew Rebacz, 02/14/2021 07:24 PM

History

#1 Updated by Zbigniew Rebacz almost 2 years ago

  • Subject changed from Header file doesn't display documentation to Header file doesn't display documentation rectangle (IDE, CodeEditor)

#2 Updated by Zbigniew Rebacz almost 2 years ago

  • Description updated (diff)

#3 Updated by Miroslav Fidler almost 2 years ago

works for me
are you aware that it takes a while after starting the ide for them to show up?
it is because processing is done in background

#4 Updated by Zbigniew Rebacz almost 2 years ago

  • Status changed from New to Rejected

I was not aware about background task. I must go directly after launching TheIDE to the Core/String.h and doesn't find any documentation link (rectangle).

Probably, it can be improved, but forcing to load after opening certain file. Anyway, no urgent

Also available in: Atom PDF