Bug #298

TopWindow incorrectly animated if popup appears

Added by Daniel Kos about 8 years ago. Updated over 5 years ago.

Status:RejectedStart date:06/12/2012
Priority:HighDue date:
Assignee:Daniel Kos% Done:

0%

Category:CtrlCoreSpent time:-
Target version:-

Description

How to reproduce:
1. Open ide project in TheIde and select Draw package and then select DrawText.cpp file
2. Press Ctrl-G
3. Find a DrawText method that has signature longer than symbol column's width (popup should appear) and leave mouse pointer there (see screenshot1)
4. Press ESC to close the window
5. Press Ctrl-G again to see incorrectly animated window during opening (screenshot2) (I guess this is vista+ issue only)

I found that this happens only if method signature is painted over the window middle.

screenshot1.jpg (339 KB) Daniel Kos, 06/12/2012 02:23 PM

screenshot2.jpg (285 KB) Daniel Kos, 06/12/2012 02:23 PM

History

#1 Updated by Daniel Kos about 8 years ago

  • Priority changed from Normal to Low

#2 Updated by Miroslav Fidler about 8 years ago

  • Priority changed from Low to High

#3 Updated by Miroslav Fidler over 7 years ago

  • Assignee changed from Miroslav Fidler to Daniel Kos

I was unable to reproduce; anyway I was doing something with DisplayPopUp recently too.

Does this problem still exist?

Mirek

#4 Updated by Miroslav Fidler over 5 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF