Bug #555

FromUtf8(), ... functions raise and exception when char *s is NULL

Added by Iñaki Zabala over 6 years ago. Updated over 6 years ago.

Status:RejectedStart date:10/30/2013
Priority:NormalDue date:
Assignee:Iñaki Zabala% Done:

0%

Category:CoreSpent time:-
Target version:-

Description

FromUtf8(), utf8len()... functions raise and exception when char *s is NULL.

The reason is that strlen(NULL) raises an exception.

This affects to ToUpper(const char*) functions.

Should FromUtf8() or ToUpper() check this or is it a matter of the programmer?

History

#1 Updated by Miroslav Fidler over 6 years ago

  • Status changed from New to Rejected
  • Assignee changed from Miroslav Fidler to Iñaki Zabala

I think that these functions are the same category w.r.t. input const char* parameter as strlen. Therefore IMO it is not a bug, you should not pass NULL pointer there.

#2 Updated by Iñaki Zabala over 6 years ago

I agree. It seems ok.

Also available in: Atom PDF