Bug #707

GetWorkArea() should track mouse cursor position (GTK backend)

Added by Zbigniew Rebacz almost 6 years ago. Updated almost 6 years ago.

Status:RejectedStart date:03/02/2014
Priority:NormalDue date:
Assignee:Miroslav Fidler% Done:

0%

Category:U++/gtkSpent time:-
Target version:-

Description

It seems that multi monitor mode when GTK Backend is enabled doesn't work properly. The problem is that GetWorkArea() should work dynamically. One of the method is to tracking global cursor position (This solution is implemented in X11 backend).

  • This patch also add "static" keyword optimalization for faster window processing (X11 equivalent).

GtkWnd.cpp Magnifier (10.8 KB) Zbigniew Rebacz, 03/02/2014 11:38 PM


Related issues

Related to Bug #725: gdk_screen_get_primary_monitor only works with GTK>=2.19.2 Approved 03/16/2014

History

#1 Updated by Zbigniew Rebacz almost 6 years ago

  • Status changed from Patch ready to In Progress
  • Assignee changed from Miroslav Fidler to Zbigniew Rebacz

Seems to be a little bit buggy...

#2 Updated by Zbigniew Rebacz almost 6 years ago

  • Status changed from In Progress to Patch ready
  • Assignee changed from Zbigniew Rebacz to Miroslav Fidler

It's OK!

#3 Updated by Miroslav Fidler almost 6 years ago

  • Status changed from Patch ready to Rejected

Because we want the work area of window, not mouse. Also with current set of methods, obtaining work area for mouse is quite easy either...

Note that all this is mostly to make it the same as in Win32...

Also available in: Atom PDF